DVD Drive Not Working

Discussion in 'Mac OS X Lion (10.7)' started by MrMinor, Jul 29, 2011.

  1. MrMinor macrumors 6502

    Jul 13, 2008
    Ever since I upgraded to Lion my DVD drive has not been working. I put a disc in and it does not show anywhere. After about 30 seconds it spits the disc out again. Has anyone else experienced this? Is there a fix?
  2. throttlemeister macrumors 6502a

    Mar 31, 2009
    Happened to me after 10.6.6. It reads CD's but not DVD's. Never been able to fix it. :( Upgrading to Lion didn't fix it.
  3. MrMinor thread starter macrumors 6502

    Jul 13, 2008
    Crap, not the answer I was looking for, but at least I know I am not alone. Misery loves company.
  4. golden-ia macrumors newbie

    Aug 11, 2011
    DVD drive not working

    Happened to me too!!! do you find any solution?
  5. Maaaaaaack macrumors newbie

    Aug 19, 2011
    Disk Utility

    I was able to revive mine by using the disk utility.

    Go to Applications -> Utilities ->Disk Utility (or command-space "Disk")

    Option-click the drive (mine is listed as "SuperDrive") and eject.

    This reset things for me, and I was able to use it again.
  6. nunes013 macrumors 65816


    May 24, 2010
    i have a similar problem. i can read but im trying to write all my vacation photos to a few dvds for the other families we went with. whenever it writes it sometimes will only write half the photos from the folder and sometimes it fails on the verify. I've wasted like 3 disks already. on the slideshow i made in iMovie it gets very laggy at parts after it has written. it never used to do this until lion. is this a lion problem?
  7. MrMinor thread starter macrumors 6502

    Jul 13, 2008
    Eject is greyed out for me. I am unable to do it.
  8. Giggleberry macrumors newbie

    Sep 10, 2011
    Just picked up my iMac 27" from Apple Store today for DVD drive replacement. On top of a mechanical malfunction, it often times did not show up in the system report.

    I didn't expect to continue to have that problem, but it is still an issue. Sometimes it shows up, sometimes it doesn't. The times it does show up, it errors out whenever I try to do any burning operations, disappears, then I can't eject the disc until it decides to populate the system report, again. Holding mouse, or eject key upon startup doesn't work.

    I even wiped my drive, and installed from scratch using SD Card installation, thinking maybe some file might be corrupt, preventing the drive from being recognized. However, the problem still exist.

    I'm thinking maybe a firmware issue...
  9. alksion macrumors 68000


    Sep 10, 2010
    Los Angeles County
    Same problem, I guess AppleCare is my only bet..
  10. Rexgom macrumors newbie

    Aug 4, 2012
    Got mine to work.

    The death of my Mac Pro optical drive would have been the third death of a mac drive. So I went to buy another and was told my Mac Pro would have have had to be returned to Apple for repair. So I just used optical drives on other machines via my network, a PIA but it worked.

    Last night I was given a DVD with some exe's on so just on a whim I ran VM and windows and much to my surprise the optical drive loaded the exe and ran.
    When finished I shut down VM and went back to iOS and the drive works.

    I haven't yet switched off to see if I have to run VM & XP each time I want the drive but at least I know it wasn't the third Apple drive to die.

    If this gives anyone a clue as to where the real problem is then please let us know.

Share This Page