DVD drive stopped working after installing Mavericks

Discussion in 'OS X Mavericks (10.9)' started by powersurge, Mar 7, 2014.

  1. powersurge macrumors member

    Joined:
    Apr 30, 2008
    Location:
    Pensacola, FL
    #1
    I'm stuck and not sure how to fix this issue. I did a clean install of Mavericks (was using snow leopard) and now my DVD drive won't read discs (Audio cds, games, movies, you name it). It worked fine before in Snow Leopard and I can still boot from DVD so its not the drive itself.

    I've tried resetting the NVRAM/PRAM and resetting the SMC as suggested on other forums but like many others it didn't help. The drive spins up twice then ejects the disc no matter what I use but I can pop a snow leopard boot dvd in and boot directly from it fine. Oh and yes the DVD drive does show up in disc utility and about mac it just won't read any discs.

    I have a late 08 Macbook Pro and I have some software thats dropping support for Snow Leopard so I'm stuck either I roll back to Snow Leopard or I can't use my DVD drive. The only thing I haven't tried yet is reinstalling Mavericks again but I've seen on other forums where people with the exact same issue tried that and it didn't help so I'd rather not waste my monthly bandwidth on reinstalling the OS for no reason.

    Any ideas guys? :confused:
     
  2. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #2
    Did you ever install a cracked region-free firmware on it?

    ----------

    Also found this:

    https://discussions.apple.com/message/24032581#24032581
     
  3. powersurge thread starter macrumors member

    Joined:
    Apr 30, 2008
    Location:
    Pensacola, FL
    #3
    Nope stock firmware and I tried those commands a few times but it didn't seem to help. I've been searching through posts of other people who have the exact same issue but so far none of the ideas that have been posted have helped me. Some of the replies suggest that it was merely a coincidence and the drive just died but I can boot from mine just fine (snow leopard install dvd). It just won't let me read any discs while in the OS. Discs spin a few times then they are ejected.
     
  4. powersurge thread starter macrumors member

    Joined:
    Apr 30, 2008
    Location:
    Pensacola, FL
    #4
    I think I might of fixed mine. I had tried the various drutil commands a few times and given up without it working but I came across several posts including the one quoted below (apple forums) that suggested just repeatedly spamming the commands to "wake up" the drive and it seems to have worked. I was able to install a small game and listen to an audio cd after spamming these commands 20 or so times (with the disc in and out of the drive).

    I'm still very confused as to why it just stopped working within the OS after installing Mavericks (yet I was still able to boot from the DVD just fine). Clearly something is bugged in mavericks. I even came across a post on the apple forums from someone with this issue and it was effecting both his late 08 and early 2013 Macbook Pros.

    I'll keep an eye on my own machine to see if it stops working again but for now it seems my drive is "fixed" go figure. :confused:
     
  5. jpmacattack macrumors newbie

    Joined:
    Dec 10, 2014
    #5
    It worked!

    I have the same problem on a late 2010 MBP. After several hours searching I found one similar fix in various forums. I tried it.

    I entered the following in terminal SEVERAL, SEVERAL TIMES- with a cdRW disc and a music cd in and out of the drive.

    drutil status

    drutil info

    drutil getconfig

    drutil eject

    I had accidentally entered drutil statu and received this info:
    Usage: drutil -drive [drive-arguments] command [command-options-and-arguments]

    drutil commands are:

    atip Displays ATIP information about inserted CD-R/RW media.

    bulkerase Bulk erases -RW media in either quick or full mode.

    drutil bulkerase (quick | full)

    burn Burns a given file or directory to disc.

    drutil burn (burn-options) <path>

    cdtext Displays CD-Text present on an audio CD.

    discinfo Displays disc related info when media is present.

    dumpiso Parses ISO-9660 directory structures.

    drutil dumpiso <devnode> <block> [format]

    dumpudf Parses UDF directory structures.

    drutil dumpudf <devnode> <block> [format]

    eject Ejects media from the drive (if any).

    erase Erases -RW media in either quick or full mode.

    drutil erase (quick | full)

    filename Translates filenames for different filesystems.

    drutil filename <name>

    getconfig Displays current and supported device features and profiles.

    drutil getconfig (current | supported)

    info Displays detailed information about connected drives.

    list Lists all connected burning devices.

    poll Constantly polls and displays device notifications.

    size Estimates size of a given file or directory.

    status Displays detailed information about inserted media.

    subchannel Displays subchannel (MCN, ISRC) info when CD media is present.

    toc Displays TOC information about inserted CD media.

    trackinfo Displays track related info when media is present.

    tray Opens and closes drive tray, and ejects media.

    drutil tray (open | close | eject)

    version Display the OS and DiscRecording version numbers.

    (specify drutil help <command> for command specific help)

    (specify drutil help driveselect for drive selection help)

    Since I know the cdRW disc was recognized in disc utility and when I entered drutil status, I decided to focus on the music cd. Whenever the music cd was in the drive it would give me Type: No Media Inserted.

    I started entering drutil toc, drutil cdtext and drutil status several MORE times.
    I was about to give up when I remembered reading a post that stated he had to enter them a bunch of times over and over and come back 5 minutes later over and over and then it finally started working.

    So I decided NOT TO GIVE UP YET. Just after I entered drutil status the next time it kind of paused like it hadn't done before. Then I could feel the drive start to come to life! Then the information for the cd I had in the drive showed up instead of no media inserted! I entered the rest of the commands.

    Then booyah! iTunes opened and asked if I wanted to import the songs!

    CD is working now fine. BUT... my celebration was cut short when I tried a dvd and it still is not working. I finally got it to read the media in the command prompt, however it is not showing up in Finder or the dvd player.
     

Share This Page