DVD is jittery like a claymation movie

Discussion in 'macOS' started by TheNorthWaves, Mar 26, 2008.

  1. TheNorthWaves macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #1
    so my GF came over last night and brought that new dvd set about the serial killer cop... well, my mini c2d with 10.5.2 played it, but horribly. It is an original DVD, all other programs except dvd player were closed. The audio stream was fine, but the video refresh rate was horrible... very noticeable. I didn't notice this in 10.5.1 - anyone else know what's going on? We're supposed to watch more of it tonight, I'd like to fix it.

    Thanks
     
  2. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #2
    Check Activity monitor to make sure that no processes or daemons are using a lot of your CPU cycles. Even if all your applications in the dock are closed, you might still have stuff running in the background.
     
  3. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #3
    dumb question here, but what would you consider excessive CPU usage?
     
  4. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #4
    Well, if when you're not doing anything with no applications open your CPU is more than 25% consistently taxed, you've got something using too much. But for DVD player to studder like you described, you'd have to be close to maxing out your CPU when not playing the DVD.
     
  5. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #5
    given that my CPU would have to be under a lot of stress (which it doesn't appear to be whatsoever), can we assume until I get home that there's something else causing the problem? I'd just like to get opinions and check out a few things when I get back.

    Thanks everyone
     
  6. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #6
    Sounds to me like DVD Player's new de-interlace engine is getting messed up (detecting cadence incorrectly, bad cadence on the tape) or something to that effect. That seems more likely than the CPU being too overstressed to do MPEG-2 decoding (which in this day and age is pretty low in terms of demands).

    EDIT: Or maybe you're experiencing screen refresh tearing?
     
  7. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #7
    The weirdest thing about it is that it suddenly came up - I've watched plenty of DVDs without this problem up until now.
     
  8. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #8
    That makes it sound like what killmoms is describing with the deinterlacing. You could try turning off the deinterlacing and see if it plays any smoother.
     
  9. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #9
    another dumb question of mine - how do i turn of deinterlacing, and should I leave it turned off (will it affect my video performance in other things, etc?) Sorry I'm not too experienced in this sector.
     
  10. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #10
    It's a menu item in DVD player. I'm not at my mac, so I'm not 100% but I think it's under the view menu. You probably don't want to have it off for other DVDs that work fine with it on since you probably don't want to see the little horizontal lines from it.
     
  11. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #11
    What resolution is the screen? Does it play fine if it is just in a small window? I have observed that GMA integrated graphics can become crappy once the resolution surpasses a certain point.

    And have you installed the Leopard Graphics Update after you installed 10.5.2?
     
  12. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #12
    I turned off deinterlacing, no dice. I've played plenty of movies @ fullscreen before, without an issue. Did the 10.5.2 combo update plus the graphics update. My ancient powerbook plays DVDs really well, heh.
     
  13. TheNorthWaves thread starter macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #13
    fyi, I rented an itunes movie and it played at fullscreen perfectly...
     

Share This Page