DVD Shrink under Parallels

ripfrankwhite

macrumors regular
Original poster
Dec 13, 2005
184
5
Anyone here using DVD Shrink with Parallels? I can't seem to get it to rip the disc. It works fine under Bootcamp, but fails to work with Parallels.
 

ripfrankwhite

macrumors regular
Original poster
Dec 13, 2005
184
5
gloss said:
Haven't tried, but I've got to ask...

Why not just do it in MacOS?
Mac doesn't have any decrypters that can compete with the ones for Windows.
Mac the Ripper is as good as it gets on Mac, and it just doesn't cut it for the newer discs. Especially Sony and Disney.
 

br0adband

macrumors 6502a
Aug 29, 2006
933
69
It's not working because of how Parallels accesses the physical CD/DVD drive in your machine. I have the same issues with drive access under XP inside Parallels; the virtual driver doesn't allow for most stuff like raw level data ripping, unfortunately.

Hope this helps...
bb

ps
If necessary, try this (although it takes longer): Use Disk Utility to make a CD/DVD master file (.cdr but you can just change that to .iso, it's the same thing) of the DVD on the hard drive, then mount it with Disk Mounter and *then* try to rip with DVDShrink or do whatever with it. This way you're bypassing the virtual CD driver totally. So, image the CD/DVD to a shared folder on the hard drive under OSX, then fire up Parallels/XP and point DVDShrink to the mounted image file in the options (just like choosing a physical drive/ISO image to use to install stuff under Parallels).

Takes a lot longer but, you may end up getting the results you want.
 

randomlinh

macrumors newbie
Oct 19, 2006
28
0
I'm geting a "ran out of space, don't have enough memory" error when it gets to encoding. @exactly 44% on two dvds now. Both straight from DVD, and straight from an ISO.

my parallels setup is a 20GB full disk (it was expanded, i converted it.. I hope that's not the problem). I tried saving it to that, and to the parallels shared folder.. both failed.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.