DVD Stuck in iMac (OS X 10.7) - It's not showing either!

Discussion in 'iMac' started by hsaleem, Aug 12, 2011.

  1. hsaleem macrumors newbie

    Joined:
    Aug 12, 2011
    #1
    Hi,

    This is my first post here and I need some help.

    I have an 18 months old iMac (2.66 GHz Intel Core 2 Duo) - Yesterday I was watching this DVD and I got a message "Skipping over damaged media". The DVD didn't go any further. I ejected it and inserted it again but it gave me the same error again and stopped. Since then I haven't been able to eject or play the DVD. The disc isn't even showing on my desktop. When I click on DVD Player, it gives me this message "a valid dvd drive could not be found 70012"

    I have tried a few things like holding the mouse down while rebooting but it won't work. I tried rebooting while holding the options/control keys but it won't show the disc.

    Can you please help me get rid of this problem?

    Thanks in advance.
     
  2. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #2
    If the mouse on reboot doesn't work, chances are that the drive died. Do you happen to have AppleCare on the system, or did you buy it with an Amex card?
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    It sounds like your optical drive is failing. Do you hear it make noise when you turn on your iMac?
     
  4. hsaleem thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #4
    blevins321: Nah I don't have the Apple plan. Also I didn't buy it using an Amex
    Intell: I heard it a few times yesterday but now it doesn't make any noise at all.
     
  5. obsidian1200 macrumors 6502

    obsidian1200

    Joined:
    Jun 19, 2010
    Location:
    Albuquerque, NM
    #5
    I've had this problem on my iMac a few times. I fixed it by rebooting the machine and holding down the eject button as it booted back up. Usually spat the disc right out and the drive went back to normal. That's something else you can try.

    If that doesn't work, I'd agree with the two other posters in that the drive is dying or dead. Even without Apple care, assuming there's an Apple store nearby, you can make an appointment with the genius bar and take your iMac in for diagnostic and repair, albeit an out of pocket expense. If there's not, try looking for an Apple Authorized Service provider and see if there's anything they can do for you. Apple's website has a tool you can use to locate authorized servicers in your area. Regardless of what you do, make sure you get your DVD back ;) I've had a few friends take in PCs suffering from dead drives, and they never saw the disc inside the drive again.
     
  6. GeekGuys macrumors regular

    Joined:
    Mar 13, 2009
    #6
    Same here!

    Hi,

    I've had this a couple of times now on my 2008 iMac. First time it lasted about 2 weeks, then appeared back on the desktop and ejected without issue. No reboots or anything....just time.

    This time I have tried EVERY trick..... nothing. If I reboot, I can see the disk, it spins up (although sounds terribly ill) and I can read the contents.
    If I press eject, it goes from the desktop and then tries to eject, fails... a few crunches and then tries again... this goes on for about 2 days, then stops making noise other than every 30 seconds you can here it 'thinking' about spinning up but not bothering.

    I can repeat this over and over but none of the tricks work to eject the disk. I've tried them all.

    My last resort is to remove the screen and take the drive apart.... but I've only just removed the screen to replace the HDD so I am reluctant. Also, if I take it apart, do I replace the DVD unit anyway, or is it just a crap disc?

    I do this sort of thing for a living but with my own personal machines.... I just never have the time to do anything....:p
     
  7. hsaleem thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #7
    obsidian1200: I just tried that. It took ages to boot up with the eject key pressed down but nothing happened!

    I can build/assemble my own PC so I want to ask if it's easy to remove this drive and replace it with a new one? Or is it too risky? I have a lot of data on this computer and I don't want to risk damaging the disk drive.

    GeekGuys: I read somewhere that I need to boot it up and leave it for 15-20 minutes and it would automatically eject but I left it for a few hours and nothing really happened.
     
  8. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #8
    dont hold the eject key hold the mouse buttons in with a usb mouse plugged into the mac
     
  9. hsaleem thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #9

    I was using apple magic mouse but after Your suggestion I saw a ray of hope and switched to a USB mouse. I rebooted with the Left button pressed down but nothing happened. It took ages to reboot but then no signs of a dvd
     
  10. Stonefly macrumors regular

    Stonefly

    Joined:
    Dec 26, 2009
    Location:
    Nova Scotia
    #10
    that happened to me once to. I had to shut down the computer, unplug it for a couple of minutes then reboot while holding the eject key. If it don't work with the eject key do that again and try the mouse method.
     

Share This Page