DVD stuck slot loading powerbook trick.

Discussion in 'PowerPC Macs' started by mymemory, Oct 9, 2005.

  1. mymemory macrumors 68020


    May 9, 2001
    Ok, I have a 12" PB and latelly became a nightmare with the stuck CDs. Usually it does not want to eject CDs/DVDs from companies but it handles fine virging cds/dvds. ¿? Probably there is some formating in the industrial kind of CDs outside, who knows.

    Well, just want to open this thread for people with the same problem.

    My solution:

    If the drive tries to eject but can't and end up mounting the CD again. Just take another CD and when you press eject again push that CD into the slot but just one third and you will see the stuck CD coming out with no problem as well.

    It seems there is a sensor or something that obviously does not work well.

    I inserted a virgin CD and the drive worked just fine and ejected later on, but a CD as the installer for my Linksys get stuck and some other softwares too.

    That is it.
  2. wdlove macrumors P6


    Oct 20, 2002
    When I've had a problem usually a restart works.
  3. mymemory thread starter macrumors 68020


    May 9, 2001
    In this case not even that.

    A friend of mine gave me a CD yesterday and I couldn't get it out. Even restarting with the mouse botton pressed, nothing worked.

    I saw in a forum a few days ago that inserting a sheet of paper whould help the cd to come out. I used another CD this time.

    My PB was trying to eject but nothing came out and the disc was mounted again.

    I mean, I was about to go to Apple service this time but I tried the hard way and worked just fine.

    The other time that happened I took apart the entire computer but the optical drive was in a single piece. To take apart a powerbook now days takes a lot of talent, is not like the old Pismos. Well, that time the disc came out itself later on.
  4. neocell macrumors 65816


    May 23, 2005
    Great White North
    Whenever I've had a problem ejecting a disc from my PB I've restarted, held command+option+O+F then at the cursor typed in eject CD and then mac boot and bob's your uncle
  5. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Restart with mouse button depressed (poor little thing) has never failed for me. :)

    I'm not sure I like the idea of shoving in another disk when one already occupies the drive. :eek:
  6. powerbook911 macrumors 68040


    Mar 15, 2005
    when this happens to me, I found a better way than restart.

    Put the computer to sleep!! :) When it wakes up, it re-detects the disk. Works for me.
  7. iEdd macrumors 68000


    Aug 8, 2005
    Force quit any screwy applications.. Such as itunes, when a disc is in and it freezes or something.
  8. marcusinlondon macrumors newbie

    Sep 21, 2007
    Paper Trick Worked a freakin' treat!!

    OMG!! :)

    I was loading a software update [pro-tools 7.3.1] and the DVD got stuck in the drive ... there were tears ... I even took out the two little screws in a vain attempt to remove the silver top ... I looked on here ... saw the paper suggestion and thought I'd give it a shot. I was skeptical ... my friend Nadine said - 'your telling the universe not to make it work' [under her breath she told the universe to 'make it work' - she's in touch with these things] so I inserted a CD width piece of paper and out it popped - first try!!!

    Thank you, thank you, thank you.

    I love you.

    God, how I love you.
  9. Alienbrain macrumors member


    Sep 11, 2007
    New England
    This and the mouse button has always worked for me... Glad I have only had to do it a few times.

    Thanks for posting this thread tho, I am sure this will help out some folks. :)
  10. maradnus macrumors newbie

    Sep 27, 2007
    stuck drives

    I have the same problem on my 12" but i don't have a disk in the drive!! I opened it up this morning and removed the disk as nothing else would work. Now it still thinks there is a disk in the drive and is trying to eject it. im at a loss as what to do now. I have done a PMU PRAM and still nothing. As far as i know when a disk is in it pops a bit up i front of the slot so you dont put a another disk in, and that bit is still there. ???? :confused:

Share This Page