DVD with 99 titles not ripping in widescreen

Discussion in 'Apple TV and Home Theater' started by paulisme, Jan 15, 2012.

  1. paulisme macrumors 6502

    Joined:
    Dec 15, 2008
    Location:
    Charleston, SC
    #1
    I've got a DVD that uses the 99-title trick to make it difficult to rip. I followed the usual steps by opening the DVD in the Mac DVD Player app and grabbing the title number. I used HandbrakeCLI to rip the appropriate title since the Handbrake GUI was taking forever to scan all the dummy titles. It worked for the most part; the one issue I have is that the video ended up with a 4:3 ratio instead of 16:9 like it should be, and the image isn't "squashed," it's cropped on the sides. Any suggestions for ripping this video properly?
     
  2. obsidian1200 macrumors 6502

    obsidian1200

    Joined:
    Jun 19, 2010
    Location:
    Albuquerque, NM
    #2
    I don't use the CLI for handbrake, but this might help you. In the handbrake GUI (for OSX at least, I'm not sure about the other builds), there's an option to scan a specific title within a source like you do with the CLI. In OSX, it's found under the "File" menu. I'd suggest trying the GUI to see if you can fix the cropping issue manually through that.

    However, if you want to figure out how to fix it with just the CLI, you can set custom cropping parameters, which can be a bit tricky without a preview window to help you.

    From the Handbrake CLIGuide (https://trac.handbrake.fr/wiki/CLIGuide) :

    Code:
    -l --crop <T:B:L:R>
    This will let you set your own cropping values for the top, bottom, left, and right (use even numbers for best results).

    Hope this helped and good luck.
     
  3. paulisme thread starter macrumors 6502

    Joined:
    Dec 15, 2008
    Location:
    Charleston, SC
    #3
    obsidian, using the "Open Source (Title Specific)" option worked perfectly. Once I did that, I could see that Handbrake wanted to crop the sides of the video for some unknown reason. I just changed the crop option to manual and set it to 0 on each side and it ripped correctly. Thanks for the tip.
     

Share This Page