DVD Won't Eject, Please Help

Discussion in 'MacBook Pro' started by benhollberg, Dec 19, 2010.

  1. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #1
    I inserted a DVD into my MacBook Pro, it said it was a blank disc, even though it wasn't, and asked what to do. I pressed eject because clearly something was wrong. Now it won't eject. It is in the drive like nothing is there. I have tried logging out and back in and restarting the computer. What is can I do? Has this happened to anyone else? Please reply with help.
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    Restart your computer, and press and hold your mouse button (or trackpad) while it boots up (from the time it turns back on until you see the spinning grey gear). This should eject the disk.

    We have a Guide on the issue here: http://guides.macrumors.com/Force_Eject_a_Stuck_CD_or_DVD
     
  3. benhollberg thread starter macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #3
    That worked thanks so much.
     

Share This Page