Dvorak-Qwerty Command and Word

Discussion in 'Mac Apps and Mac App Store' started by dws90, Jan 16, 2008.

  1. dws90 macrumors regular

    Jan 16, 2008
    I use the Dvorak keyboard layout on my MacBook Pro, but like to use the Dvorak-Qwery Command option, which means that Cmd+* uses the Qwerty layout (When I try to use Dvorak for Cmd, I always end up pressing Cmd+Q when I don't mean to).

    This works great in every app I've tried so far, except for one: Microsoft Word (and possibly the other Office apps as well). Initially, I dismissed it as a problem with Word 2004, and figured it would be fixed in 2008. I was mistaken - kind of.

    I'm using 2008 now, and what I get when I press Cmd-something seems to switch randomly between layout - sometimes pressing Cmd+Qwerty S opens the save dialog box (Qwerty), while other times it opens the Open dialog box (Dvorak). Cmd-Qwerty B performs a cut (Dvorak), but Cmd+Qwerty N creates a new document (Qwerty). If I want to bold text, I'm out of luck.

    This flip-flopping makes keyboard shortcuts in Word almost unusable. Switching to Dvorak completely would fix the problem, but I'd rather not do that because of the aforementioned Cmd-Q thing. Therefore, is there a way to:
    1. Get Word to actually recognize the commands correctly, like every other application seems to manage easily.
    2. Switch the keyboard layout Word uses to Dvorak (without Qwerty-Command), but leave Qwerty-Command as the layout for the rest of the system.

  2. yfyfyf macrumors newbie

    Jan 19, 2008
    hello mate thought i'll bump this thread a bit since i have the same problem....

    M$ software really suck on macs, from what i can tell (i am on office08, macbook, Leopard) some shortcuts still work, but most of them are engaged literally by the new Dvorak Key.... in other words, Word08 has totally disregarded DQ input and treating it just like standard Dvorak in...... pain in ass!
  3. nadyne macrumors 6502a

    Jan 25, 2004
    Mountain View, CA USA
    I asked the Word team to look into this. (Sorry, I didn't see the thread back when it was first posted!) We confirmed the reports here, and now they're logged in our database.

    At our first gloss (I emailed them Friday night, just got an answer now), it looks like there's a couple of different things going on here. One is that there's a timing problem -- depending on how quickly you press a letter key, if you're too fast, it will register as the qwerty key instead of the Dvorak key. That's what's happening in the Cmd-S vs Cmd-O scenario. The second problem is the incorrect mapping one, which is what you're seeing with Cmd-B.

    For the timing issue, you could workaround it by being slower with your keyboard presses. For the incorrect mappings, you'll have to use a menu or toolbar button. Neither of these great solutions, I know. :(

    I was a bit surprised to see that we had problems here, since a couple of people on the Word team are Dvorak users. (Me, I'm a qwerty girl -- I type 120+ wpm, so I don't think I could reprogram my fingers!) But they're all straight Dvorak users, not Dvorak-qwerty, so it seems we missed it.

    Sorry I don't have a great answer here, but I do want to thank you for reporting it.

  4. Joel Kalvesmaki macrumors newbie

    Dec 15, 2008
    Another QWERTY - Dvorak problem

    I am a longtime user of Word 2004 for Mac (I won't go to 2008 because I use VBasic in my work). I am also a Dvorak user of about 10 years. Only tonight (12/15) I downloaded the update for Office (11.5.3) and my Dvorak support is all wacky. That is, I can type in Dvorak just fine, but anytime I hit a command that requires the control key it treats the keyboard as if it were Qwerty.

    This seems to happen also with the command key, but the behavior here is erratic. When I first open Word and hit Cmd+O for open I get the "Save As" dialogue box (as if I was using Qwerty and pressed Cmd+S). But then when I roll my mouse over the menu items and then return to the document and hit Cmd+O again then I get the "Open" dialogue box. Even stranger, once this is ok, I go to the Customize Keyboard dialogue and hit a few test keys in the "Press new shortcut key:" box it reads my keyboard once again as QWERTY for both command and control!

    I tried the suggestion made to delay hitting the key combination, but that doesn't do the trick.

    This is afflicting only Word, and a modified version of the problem occurs also in Excel. I've detected no problems in Entourage or in Powerpoint.
  5. dulles macrumors newbie

    Dec 16, 2008
    I just downloaded the OS X update and now Dvorak Command keys in Word are acting up on me as well. For example, when I hit Command-X to cut, it treats it like a Command-B (X in Dvorak is where B is on a Qwerty layout). However command keys that go to the system, such as Command-Q and Command-M continue to work as expected (that is, I hit the Dvorak Q or M and the application quits or minimizes).

    I don't think I installed the latest Word update, but I'm about to do so. Seems it won't hurt anything.
  6. Joel Kalvesmaki macrumors newbie

    Dec 15, 2008

Share This Page