DYMO LabelWriter PnP not recognized as printer

Discussion in 'macOS Sierra (10.12)' started by WhiteWhale, Nov 4, 2016.

  1. WhiteWhale macrumors newbie

    Joined:
    Nov 4, 2016
    #1
    The DYMO LabelWriter PnP does not get recognized by the DYMO Label nor the System as a printer under macOS Sierra. It does work with the Software that comes with the LabeWriter but it is fairly inconvenient since I have 2 DYMO products running and would prefer to use them with only one program. I'm running the latest version of DYMO Label (8.5.4) and macOS Sierra (10.12.1).

    Does anyone know this problem or even how to solve it? Thanks for an answer in advance!
     
  2. FreakinEurekan, Nov 4, 2016
    Last edited: Nov 4, 2016

    FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    Working fine for me, so it's not a generic compatibility issue with the printer & Sierra or with Dymo Label. As far as how to fix, start isolating - disconnect other devices, test in Safe Boot, maybe set up a new user account & test there.

    Edit: Noticed I was on Dymo Label 8.5.2 and no updates shown available, so I went out to Dymo and downloaded 8.5.4 and installed. Now seeing same symptoms, printer which was available in System Preferences is now gone. Investigating.
    --- Post Merged, Nov 4, 2016 ---
    So, here's what I have so far. I installed Dymo Label 8.5.2 from the Support tab at http://www.dymo.com/en-US/labelmanager-pnp-label-maker on a different Mac also running 10.12.1, and the printer works fine there. Shows up in System Preferences, Dymo Label works. It did not show up as a printer until Dymo Label 8.5.2 was installed.

    I deleted Dymo Label 8.5.4 from the original machine and reinstalled 8.5.2, still nothing here. It seems that the 8.5.4 installation has done something to prevent this from working.

    I sent a support request to Dymo on this, will update here if I find a solution.
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    I got it working.

    1. Delete /Applications/Dymo Label.app
    2. Delete /System/Library/Extensions/DymoUsbPrinterClassDriver.kext
    3. Delete /Library/LaunchAgents/com.dymo.dls.webservice.plist
    4. Delete /Library/LaunchDaemons/com.dymo.pnpd.plist
    5. Restart
    6. Install Dymo Label 8.5.2 from http://www.dymo.com/en-US/labelmanager-pnp-label-maker Support tab
     
  4. jamessezhi macrumors newbie

    Joined:
    Oct 11, 2013
    #4
    THANKS A LOT!!! Worked perfectly. Spent over 1hr with DYMO phone support and even they didn't know about this fix. Am using MaxOS Sierra...

     
  5. kaerukodo macrumors newbie

    Joined:
    Jul 23, 2017
    #5
    OH MY !!! Thank you SO MUCH for sorting this printing problem out !!!!!
    Not very confortable with computing, I used an app to delete my Dymo label files and then install the 8.5.2 (I'm on Sierra and tried before to install the 8.5.4 and it didn't work): everything went very well, very easily !
    Great info, thanks again
    :):):):):):apple:
     
  6. martyr macrumors newbie

    martyr

    Joined:
    Jun 19, 2007
    #6
    I still couldn't get this to work on macOS Mojave. What a joke this DYMO software is. It's 2018 and your Mac support is dismal. I ended up launching my Boot Camp on VMWare and creating the labels that way. What a joke.
     

Share This Page

5 November 4, 2016