e-mail set up for Demon UK? Won't send e-mails

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rollei, Aug 29, 2008.

  1. rollei macrumors newbie

    Joined:
    Aug 4, 2008
    #1
    I'm having difficulty sending e-mails from my Demon account on my iPhone 3G. I've set it up to use post.demon.co.uk as the primary outgoing mail server and I've added smtp.o2.co.uk as an alternative. I'm in the UK.

    When I'm out and about it comes up with the error - Cannot Send Mail "One of the recipient addresses was invalid". This is the case on 3G and any other connection. When I'm at home and on wi-fi it works fine! The addresses I'm using are correct as they work from home and on my other account!

    My .mac/MobileMe account works perfectly. I use Demon for my business and .mac for the family.

    Any ideas?
     
  2. TrevorcH macrumors newbie

    Joined:
    Aug 30, 2008
    #2
    iPhone can receive but not send Demon email

    I've just been told by O2 iPhone support that despite any O2 or Apple support documentation it is not possible to send email through the Demon smtp server from an iPhone. I have a 3G but I don't think they differentiated in their statement.

    I can receive mail perfectly but any attempt to send mail through the Demon smtp server fails with 'invalid recipient address'. So I tried following the Apple web support which says it should be routed through the O2 smtp server and then I get a connection error. I imagined I had some login credential problem and contacted O2 iPhone support. The first operator said that it would be easily solved and tried getting me to do the same things I had tried and they all failed in the same way. I then got cut off and called again. Once I was through the lengthy queue, the second operator just told me that it isn't possible. I queried that and asked for a clear statement. I'm currently awaiting a call from Demon or Apple to confirm that it isn't possible. I'm not holding my breath and I remain somewhat incredulous that there isn't a solution.

    Incidentally, along the way I tried different permutations of port 25 and 587 as it is a bit confusing which is correct (25 seems to be the published one but the default in the iPhone software seems to be 587) but could get none to work.
     
  3. TrevorcH macrumors newbie

    Joined:
    Aug 30, 2008
    #3
    Got it working with help from Apple telephone support. Clearly the O2 support was misinformed.

    Deleted all mail accounts on the iPhone. Re-booted. Recreated my mail account. Incoming details as before for pop3.demon.co.uk. Outgoing to smtp.o2.co.uk. Left user name and password with the default 'optional'. When it tests the connection it fails and says 'do you want to try with SSL off' - say Yes. After 30 secs-ish it finally ticked all the selections and the account was set up and I could send mail for the first time.
     
  4. Matthew Bostock macrumors newbie

    Joined:
    Dec 27, 2009
    #4
    What if I am on Orange ??

    I have the iPhone 3G on Orange. Can I still use the smpt.o2.co.uk server, or do I need something else. This is becoming incredibly frustrating now.
     

Share This Page