Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

nxrz

macrumors newbie
Original poster
Aug 2, 2022
3
1
I‘m in ****ing shambles. I bought the new Apple TV 4K and sold my 1. Gen 4K - only for the eARC feature, for my Xbox Series X.

I got 2 OG HomePods and an LG CX OLED TV.

Now, I installed the Apple TV, set it up, and instantly turned on the eARC feature. I switched to my Xbox and… holy ****! It worked without any configuration (I just wanted to try it first before changing any settings). IT WAS AMAZING.

The Apple TV shipped with tvOS 15.3. Now, what you do when you get a new device? You update the firmware. So I updated to 15.6 and… eARC stopped working: **My Xbox doesn’t play any sound, no matter what I‘m doing.**

The settings in the TV should be fine, even though I still tried to change any relevant setting without success.

The Apple TV seems to recognize the ARC signal, because when I switch to the Xbox and then back to the Apple TV, whatever I‘m playing has stopped and also the navigation sound is not present anymore. No sound from the Apple TV at all until I play any media again. But 0 sound from the Xbox.

I then installed the tvOS 16.0 Beta - without success. Note: it stopped working with 15.6, not with 16.0!

What I tried:
- power cycle everything (HomePods, TV, Apple TV, Xbox)
- changed HDMI port (Xbox)
- reset Apple TV and TV to factory settings
- changing every relevant setting on the Apple TV, TV and Xbox

I just don’t know what to do. This is massively disappointing since this was the only reason I bought the new Apple TV. And it worked once on 15.3…
 

Prorege1

macrumors regular
Jun 21, 2020
215
289
I (always) suspect the cables - have you tried to run a HDMI connection test in the Apple TV settings?
I have the Xbox S with no issues on TVos 15.6 & 16,0.
 

nxrz

macrumors newbie
Original poster
Aug 2, 2022
3
1
I (always) suspect the cables - have you tried to run a HDMI connection test in the Apple TV settings?
I have the Xbox S with no issues on TVos 15.6 & 16,0.
The cables are fine. The connection test is successful. I mean, it also worked like that for a bit @ 15.3.

I will try another HDMI cable later, nonetheless…
 

thatJohann

macrumors 65816
Jul 5, 2013
1,217
938
NYC
EARC is def broken on tvOS 16 beta 4. Interesting you had the issue on tvOS 15 as well. I didn’t. But anyway I haven’t found a way to fix it so I had to disable eARC for now. Hope next beta next week fixes this.
 

ScrumpyDaniel

macrumors regular
Apr 15, 2019
202
219
EARC is def broken on tvOS 16 beta 4. Interesting you had the issue on tvOS 15 as well. I didn’t. But anyway I haven’t found a way to fix it so I had to disable eARC for now. Hope next beta next week fixes this.
Hopefully people have actually sent feedback to Apple regarding this so they can fix it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.