Early 06 Macbook running windows, upgrade firmware?

Discussion in 'MacBook' started by Zazam, Feb 23, 2013.

  1. Zazam macrumors newbie

    Joined:
    Feb 23, 2013
    #1
    I have a Macbook1,1 which currently has Windows 7 installed. The original hard drive was corrupt, so I replaced it with another from another computer (which had Windows 7 on it). I would just stick with Windows 7, but audio drivers are pretty much nonexistant for this combination. I have a white replacement OS X Tiger disk, as well as a USB Snow Leopard install. Ideally, I'd like to put snow leopard on it, but I can't actually get it to boot anything except Windows. Booting and holding C just gives me Windows boot manager.

    I tried using a different hard drive, formatted to HFS+, and it just went to a black screen saying "no operating system found".

    Holding command during bootup gave me the option to boot Windows on the first drive, and gave me a blank screen on the second drive.

    I think I need to upgrade the firmware, but I can't get it to boot Mac OS, and I don't know how to upgrade firmware on 7.

    Basically... any ideas on installing OS X, or updating the firmware (to eventually install OS X) while running Windows 7?
     
  2. 7031 macrumors 6502

    7031

    Joined:
    Apr 6, 2007
    Location:
    England
    #2
    Not 100% on this but I'd imagine you'd need to wipe the drive using the Mac OS X installer disc, setting the partition map as GUID.

    Once you've done this you should be able to install Mac OS X.

    Hope this helps.
     
  3. Zazam thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #3
    How would I do that? Is there another way? All I can boot right now is 7
     
  4. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #4
    I might be misunderstanding your problem, but why can't you start up from the Mac OS X install disk (The Tiger one)

    Do you have a SATA adapter and another Mac? If so, connect it to the other computer by USB and format it. You could also do the install from there as well.
     
  5. James Craner, Feb 24, 2013
    Last edited: Feb 24, 2013

    James Craner macrumors 68000

    James Craner

    Joined:
    Sep 13, 2002
    Location:
    Bristol, UK
    #5
    Firstly to upgrade the firmware you can only do that in OS X, it is not possible to do under Windows, so you are correct you will need to reinstall OS X.

    If you put the OS X recovery dvd in (snow leopard). Restart the computer and keep the C key pressed down then you should be able to boot off the recovery dvd. From the recovery DVD you should be able to reformat the hard disk using disk utilities and then reinstall OS X. Once you have OS X installed you can then use bootcamp to reinstall Windows.

    Ah sorry missed the fact that you don't have a Snow Leopard DVD and it is on a USB stick instead. But you should be able to use your Tiger Disk.
     
  6. chrfr, Feb 24, 2013
    Last edited: Feb 24, 2013

    chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    Do you have another disk you can put in the Macbook, even temporarily? It's a simple process to do so.
    It's possible that by now the DVD drive isn't working properly, but it's also possible that your USB installer isn't set up properly.
     
  7. lunaoso macrumors 65816

    lunaoso

    Joined:
    Sep 22, 2012
    Location:
    Boston, MA
    #7
    Tiger is 10.4. I think you confused lion (10.7) and tiger (10.4). :) And I think the tiger disk is what came with the computer, hence it being grey/white.
     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    Heh, I guess I was posting before the coffee kicked in, you are correct.
     
  9. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #9
    Is this a machine-specific one (does it say "MacBook" on it) or is it generic? I believe that a generic one will only work on a PowerPC machine, not a MacBook.

    Nobody has yet suggested holding Option at the chime to get into the Startup Manager. From there you should be able to choose to boot OS X (with the DVD in the drive).
     
  10. Zazam thread starter macrumors newbie

    Joined:
    Feb 23, 2013
    #10
    The only disks I have are the Snow Leopard USB and the Tiger DVD. Anything I could borrow would be serialized to the original computers... When I hold "C" during startup, I get a white screen with a grey folder in the center with a question mark. When I hold Option, I get a blank screen with a black cursor. The Tiger CD I have worked on the last hard drive I used...

    I've tried formatting it from another machine (it was the only way I could; absolutely nothing works on this one), and it gave me the same result. I formatted to HFS+.
     

Share This Page