Early '11 MBP, Mavericks and Battery Woes

Discussion in 'MacBook Pro' started by jmoore5196, Nov 16, 2013.

  1. jmoore5196 macrumors 6502a

    jmoore5196

    Joined:
    May 19, 2009
    Location:
    Midwest US
    #1
    I have an early 2011 15" MBP - 2.0gHz with an SSD - which has been a beautifully-performing machine until I installed Mavericks.

    Now I have the "Service Battery" warning. Resetting the SMC and PRAM has had no effect. Attempts to calibrate the battery take it in the wrong direction ... I'm down to 39% of rated capacity after my fourth attempt to calibrate. When I started, I was at 68%. I've been tracking with Coconut but have yet to save the data ... you'll have to take my word for the numbers.

    I read the corresponding Apple discussions and wonder whether this is a purely software issue ... I have ordered a replacement battery, but I note that I did not have any battery issues before I installed Mavericks and now I'm pretty far along the path to having no battery at all.

    This is maddening, to say the least. Any ideas?
     
  2. Agent-P macrumors 68030

    Agent-P

    Joined:
    Dec 5, 2009
    Location:
    The Tri-State Area
    #2
    Try using Time Machine to restore to a backup from before you upgraded to Mavericks. If you still have the same problems than you'll know it's hardware related. If not, then you'll know it's software related.
     
  3. jmoore5196 thread starter macrumors 6502a

    jmoore5196

    Joined:
    May 19, 2009
    Location:
    Midwest US
    #3
    I actually tried that tact yesterday. TM would not let me restore anything earlier than Mavericks ... as if the system had locked out everything else. Restoring to my most recent backup took 11 hours. I suppose I'll try the replacement battery and see if it sorts itself out.
     

Share This Page