Early 2008 MBP with SMC issue? Need ideas/suggestions...

seanmuth

macrumors newbie
Original poster
Oct 28, 2012
3
0
Hey guys,

I have an Early 2008 (Penryn)MBP 15", 2.4Ghz.

A month or so ago, I pulled the mbp off the magsafe and it shut off immediately. wouldn't power back on, reset SMC, tried different batteries, different magsafes, no luck.

Swapped the small power board with one from my donor MBP, still no luck.

Was searching around here and read about the SMC bypass method (hold power, connect magsafe, then hit power again) and it worked, it boots up with full speed fans, no temp info in istat, etc.



Where do i go from here? my RAM isn't the issue, SMC bypass works with a single OEM samsung 1Gb, and with my 4gb Patriot stick.

Where is the SMC chip itself? It might have some oxidation that needs cleaning?


Any and all replied definitely appreciated!!
 

seanmuth

macrumors newbie
Original poster
Oct 28, 2012
3
0
UPDATE: I *mostly* restored SMC functionality. After a couple more SMC resets, and switching to my old Apple brand battery, I'm able to see battery stats and system temps in iStat. Power button seems to have full functionality.Turns system on from full shutdown, wakes from sleep, etc.

However, the Left Fan seems to be "stuck" running at 100% (6828rpm).

Any thoughts? Can I manually reinstall the SMC firmware update?
 

fega72

macrumors newbie
Dec 22, 2014
22
0
UPDATE: I *mostly* restored SMC functionality. After a couple more SMC resets, and switching to my old Apple brand battery, I'm able to see battery stats and system temps in iStat. Power button seems to have full functionality.Turns system on from full shutdown, wakes from sleep, etc.

However, the Left Fan seems to be "stuck" running at 100% (6828rpm).

Any thoughts? Can I manually reinstall the SMC firmware update?
Hi!
One of the temp sensors is faulty or not connected properly- I think.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.