Early 2011 13"MBP can't find intel 330 SSD

Discussion in 'MacBook Pro' started by piterlo, May 1, 2012.

  1. piterlo macrumors newbie

    Joined:
    May 1, 2012
    #1
    Recently my original 500gb harddisk failed and I decided to go for the new intel 330 SSD and replace it in the original internal sata slot

    when I tried to install from the snow leopard disc(yea I'm still on SL) the disc is not even found in disc utility

    And when I tried to update the SSD firmware it says intel SSD is either not connected or disabled

    What could I do to make it recognizable?
    Is it problem with the cable(like i read in the older posts)
    I dun hv another Mac to do CCC
    Thanks a bunch!!!
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Is it possible that the cable connecting the SSD is not fully seated?

    Perhaps some other problem on your logic board exists, that is your hard drive didn't fail, but rather a component on the logic board.

    I'm assuming that when you tried to install OSX, you opened up the Disk Utility to partition the drive and format it, and that's where you care unable to see it. Correct?
     
  3. piterlo thread starter macrumors newbie

    Joined:
    May 1, 2012
    #3
    I plug it in completely
    I even used alcohol and brush to Clean the SATA connection as some other posts have suggested
    U are right I just can't see it in disc utility

    I brought my MBP to the retailer for a check and they ran thru some tests
    All they told me is my original disc had some bad sector and thus it failed to boot
    And then they asked me to replace the hdd
    As apple SSD cost much more, I decided I DIY
    and that's why I ended up in this position :(
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    so your install disc is no good?
     
  5. piterlo thread starter macrumors newbie

    Joined:
    May 1, 2012
    #5
    Put the SSD in one of the external enclosure and omg it's detected and SL could launch with amazing speed even with USB2.0 connection

    Then i plugged another harddisk into the original internal slot
    and...it's NOT detected

    omg that could be really a problem with my logic board/cable
    i dont have applecare god i just wonder how much that would cost me

    Shall go to the repair shop again and blast them for their lousy check
     
  6. piterlo thread starter macrumors newbie

    Joined:
    May 1, 2012
    #6
    at last brought the machine back to the repair shop and found out the cable to the motherboard was disconnected

    so plug it in and everything smooth :)
     
  7. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
  8. captndave macrumors newbie

    Joined:
    Aug 10, 2011
    #8
    how did the 330 work

    have my finger on the button to buy a 330 for my 2011 13" i7 MacBook pro...can't find a consensus about which to buy so decided intel...how do you like it?
     

Share This Page