Early 2011 15” MacBook Pro - not charging, not turning on, battery indicator flashing 5 times

andsoitgoes

macrumors member
Original poster
Jun 22, 2010
64
38
Hi everyone,

I am not having a great day.

I bought a 2011 pro from a friend last year. Worked great but it just got to a point where I didn’t use it much. Had it plugged in and just chilling.

At some point who knows when over the last few months the MagSafe connector came out and has been sitting, I’m assuming it had a hard shutdown at some point.

I plugged in the cable and the light on the MagSafe goes immediately green.

the battery indicators blink 5 times if I press them

I’ve tried the SMC reset to no avail.

closest I got was following a video I found linked that had me hold the power button for 10 seconds, connected the power cable and it started to boot with the fans blasting at full speed. It would show the boot screen and I’d see the progress bar starting and it would get about 1/3rd the way and it would automatically restart again. This just continued happening and would never boot.

I’m not sure what I need to do. I’m assuming the battery is toast and I need a new one but I’d love some advice before sinking money into anything. I really don’t have a ton to spend unfortunately.

I’d appreciate any help you can provide. Thanks in advance.
 

jorgk

macrumors member
Mar 20, 2013
90
6
Don't know if this can happen by "chilling" but that models GPU is prone to fail. Search for "Radeongate".
Best remedy (if not forgetting about it) is to source a 2012 logic board and get that to work in this MPB.
 
  • Like
Reactions: andsoitgoes

andsoitgoes

macrumors member
Original poster
Jun 22, 2010
64
38
Don't know if this can happen by "chilling" but that models GPU is prone to fail. Search for "Radeongate".
Best remedy (if not forgetting about it) is to source a 2012 logic board and get that to work in this MPB.
That’s the thing, I had disabled the GPU (know all about that blooming thing) and was never activated in any daily usage.

with the other signs and signals does that match up to a failing GPU, though?

Theoretically could I take it in to get diagnosed at the Apple store? If I recall they can diagnose but won’t repair for free out of warranty.
 

DeltaMac

macrumors G3
Jul 30, 2003
9,735
2,419
Delaware
Try the SMC reset again, without the power adapter attached.
Plug in the power adapter.
Do you get green LEDs on the plug? Let it sit without disturbing for at least 30 minutes to an hour.
(Do the LEDs ever change to orange?)
Then, unplug the power adapter. Wait for about 15 seconds, then plug the adapter in again.
Do you still get green LEDs? Wait for 10 to 30 seconds - do the LEDs change to orange? If yes, leave it for a few hours/overnight.
Do you then get a charge on the battery?
A battery that may be on its last legs may fail completely if left to go completely flat, never to charge again.
If you get a charge - be sure to check in your System Profiler/Power tab, which will show you some data about the battery, like the number of charge cycles, and the amount of charge remaining, etc. If the battery is not showing any data in that window - not recognized - after the overnight "treatment", then there's no future with that battery, and simply adding weight to your laptop, with no other useful purpose. Replace it, if you can find a decent replacement. That can be a challenge for you with an older MacBook Pro.
 
  • Like
Reactions: andsoitgoes

andsoitgoes

macrumors member
Original poster
Jun 22, 2010
64
38
Try the SMC reset again, without the power adapter attached.
Plug in the power adapter.
Do you get green LEDs on the plug? Let it sit without disturbing for at least 30 minutes to an hour.
(Do the LEDs ever change to orange?)
Then, unplug the power adapter. Wait for about 15 seconds, then plug the adapter in again.
Do you still get green LEDs? Wait for 10 to 30 seconds - do the LEDs change to orange? If yes, leave it for a few hours/overnight.
Do you then get a charge on the battery?
A battery that may be on its last legs may fail completely if left to go completely flat, never to charge again.
If you get a charge - be sure to check in your System Profiler/Power tab, which will show you some data about the battery, like the number of charge cycles, and the amount of charge remaining, etc. If the battery is not showing any data in that window - not recognized - after the overnight "treatment", then there's no future with that battery, and simply adding weight to your laptop, with no other useful purpose. Replace it, if you can find a decent replacement. That can be a challenge for you with an older MacBook Pro.
I first want to extend extreme thanks. I’ve done a bit of testing and have some things to report.

so I completely removed the battery and tried booting. No go.

held the power button for 10 seconds and connected the MagSafe connector. No lights on it but it started to boot fine and then had the same issue. Half way through it just boot loops.

then I tried recovery mode. Same thing. Soon as I choose the hard drive it goes into boot loop.

then I tried safe mode and, amazingly, I got into the system! Got enough to save the files I needed, and trash what I didn’t.

tried to put the battery back in and boot to safe mode and that’s when I was greeted with new issues. Now I can’t load into safe mode and use Wifi or the trackpad. I thought I blew something on the motherboard but the trackpad worked just fine UNTIL I loaded the OS. I was still worried about Wi-Fi so I tried to boot into the drive select menu holding option. I was able to connect to wifi and use the trackpad there.

so the question I have now is does this sound like a dead battery? I am debating on reloading the OS from a USB key without the battery and see if that solves at least the boot issue, but is it worth dropping the money on a new battery? Or could this be something more?
 

DeltaMac

macrumors G3
Jul 30, 2003
9,735
2,419
Delaware
You would want to find a battery that you KNOW is good, just to test that theory of a bad battery.

You said that you don't get ANY lights on the magsafe plug. Is that still true?

Reconnect the battery. Do you get any indications on the battery status lights, after you press the test button near those status lights?
Are both the Magsafe connector and plug in good condition? (No loose parts or dirt)

Be sure to try a proper SMC reset:
Magsafe adapter attached.
Press and hold the (left)shift-Control-Option, then press and release the power button. Release all keys.
The Magsafe connector should show Green, then should change to orange/amber. If the battery is at full charge, it may not change to amber, but remain green -- and the test lights on the side should be completely on, and steady. If you get an amber magsafe LED, leave it to charge for several hours. (likely your battery is not working, but worth trying if you see green, changing to amber)
Finally, sounds like you "sorta" get power, especially if the battery is not connected. As I have said above, it can be challenging to find a decent replacement battery.