Early 2011 MacBook Pro stuck on reboot

Discussion in 'MacBook Pro' started by Bootsie, Mar 5, 2016.

  1. Bootsie macrumors 6502a

    Bootsie

    Joined:
    Jan 23, 2008
    Location:
    Utah
    #1
    so my computer has been functioning great for years, but I came home the other day, and it had shutdown. When I turned it on it just kept restarting over and over... It gets to the gray screen after the apple logo and then repeats.

    I've spent the last few days working on it and got it up and running using recovery mode and a few other things. Reinstalled the OS, and was able to back up.

    It was still running slower than normal, but seemed to be ok. I restarted a few times to see if it would start back up ok and it did. However I got home yesterday and it had shut itself off again and is now stuck rebooting again

    Any ideas what could be wrong? Do you think the hard drive is going? Something else?
     
  2. CoastalOR macrumors 68020

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    So we do not waste time suggesting things you have already tried, what specifically are the "few other things" you have tried?
    My first impression is a failing Hard Drive or drive cable. Do you have the original spinner drive installed?
    Which OS are you using? What size screen?
    Have you tried using Disk Utility to check your Hard Drive?
    When you get stuck in the reboot loop have you tried starting in Safe mode? BTW, here are some startup key options.
     
  3. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Hmmm... 2011 15-inch MBPro.
    Suddenly restarting, and perhaps other issues...
    Sounds familiar - http://www.apple.com/support/macbookpro-videoissues/

    Could be hard drive, but also might be logic board/graphics card issues.
    Take to Apple.
    Apple will test this, and if yours fails for that issue, Apple will fix it.
     
  4. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #4
    My 2011 17" did the same when the GPU failed.

    Take it to Apple as others have suggested, and if it is the GPU it will be fixed under warranty which has been extended to the end of 2016.
     
  5. Bootsie thread starter macrumors 6502a

    Bootsie

    Joined:
    Jan 23, 2008
    Location:
    Utah
    #5
    Thanks everyone! I did not know about the GPU failures of this model until today, I'm hoping that is it!

    I have check the hard drive with dock utility and it says that it is fine... I have tried safe mode and it would not work, command+R wouldn't work until I reset the NVRAM. Tried apple hardware test, it said everything was fine. Once I was about to get recovery mode to work I reinstalled the OS... It worked the best after this.
     
  6. ron1004, Mar 5, 2016
    Last edited: Mar 6, 2016

    ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #6
    My GPU problem was repaired before Apple announced the warranty extension, and when I took it in, it passed all the tests, but could not boot past the grey screen.

    I went with the $340 flat rate repair, .....which they refunded when the warranty was extended.
     
  7. Bootsie thread starter macrumors 6502a

    Bootsie

    Joined:
    Jan 23, 2008
    Location:
    Utah
    #7
    Took it in to the Apple Store and the video card failed their tests almost immediately. It is waiting at the store for the parts for repair.

    Thanks for your help! Sorry to start kind of a useless thread, but I'm so glad I don't have to shell out for the repair!
     

Share This Page