Early 2011 MacBook Pro Won't Turn On

Discussion in 'MacBook Pro' started by zflauaus, Feb 25, 2012.

  1. zflauaus macrumors 65816

    Joined:
    Nov 19, 2004
    #1
    My early 2011 MacBook Pro won't turn on today for some reason. It was fine last night when I put it to sleep but this morning there is no indication of activity.

    • The MagSafe is green but the battery lights do not come on when pressed.
    • No other peripherals are plugged in.
    • Attempted to reset the SMC, nothing.
    • Put in the original RAM (note: I've used the upgraded RAM for several months). Nothing.

    Should I just suck up the 70 mile trip to the Apple Store?
     
  2. LostSoul80 macrumors 68020

    LostSoul80

    Joined:
    Jan 25, 2009
    #2
    Yes, if it's hardware related you need professional advice. Could be anything, really.
    When you try to turn it on, do you hear anything (fans, HDD)?
     
  3. zflauaus thread starter macrumors 65816

    Joined:
    Nov 19, 2004
    #3
    Nothing at all. And the MagSafe won't light up now. Decided to call AppleCare in the mean time.
     
  4. LiesForTheLiars macrumors regular

    Joined:
    Jan 12, 2011
    #4
    Sounds like it's time to pay Apple a visit, though lugging in an iMac is a little embarrassing.
     
  5. intelssd macrumors newbie

    Joined:
    Feb 22, 2012
    #5
    My MBP wouldnt turn on once and i think it was because the back metal plate wasnt seated right.. when you tighten those back 10 screws or what not softly snug them then tighten the center first then outward. Make sure you use the right ones in the right holes two.. some of the short screws all fully threaded and some are not. The deeper looking holes can use the screws that are not fully threaded. But ya, check the ram is in right again too or seated perfect.
     
  6. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #6
    Then it's a good thing OP's machine isn't an iMac :p :p . But for serious, they'll hook you up for sure at the :apple: store.
     
  7. zflauaus thread starter macrumors 65816

    Joined:
    Nov 19, 2004
    #7
    Took it to the Apple Store and they fixed it within about 15 minutes. Apparently the SMC was just borked. They had to remove to the battery, plug it in, do a reset and then it worked fine. Works like a champ now!
     

Share This Page