Early 2011 MBP 13" won't recognise hdd when internal only

Discussion in 'MacBook Pro' started by radof94, Mar 27, 2012.

  1. radof94, Mar 27, 2012
    Last edited: Mar 27, 2012

    radof94 macrumors newbie

    Joined:
    Mar 27, 2012
    #1
    First off I want to say I've been looking for answers for this on google for a few days, and I've found similar problems but none of the fixes have seemed to help me. Then again I may be doing something wrong.

    I've recently purchased a 500GB Momentus XT to replace the stock hdd in my early 2011 mbp 13".
    Originally placed the disk in an external usb 2.0 enclosure and made a clone of my the stock disk. I could boot fine from the momentus xt when being run from the enclosure.

    Problems arose as soon as I tried to swap the drives around. Now I could boot fine from the stock drive (in the enclosure) but the momentus XT could not be booted from. I tried swapping the momentus back to the enclosure, and it still worked fine this way. I attempted to reset PRAM and Smc, and it didn't help me.

    So I tried to reformat the drive, and to make a partition of 495.11g with the rest being empty space (I read this may help). I then put the momentus into the internal bay, in hope of booting osx from the original disk over usb, and migrating the data I needed over. Disk utility could not recognise there was even a disk in the internal bay (the momentus), just as before.

    I tried updating to lion (I was on snow leopard before) and turning it on again, but still disk utility couldn't even recognise the presence of the momentus xt when used in the internal bay.


    I have noticed that I am having trouble updating the EFI firmware to version 2.7. Every time I try, it runs through the installation, restarts, says install was complete. But when I go to system update, it still lists this as an update, and system profiler still says I'm on the older version. Yes, I have tried updating it using the package from the apple website, it is no different.
    Could this have anything to do with my hard drive problem at all?
     
  2. Dekard macrumors 6502

    Dekard

    Joined:
    Sep 7, 2011
    Location:
    Dallas, Texas
    #2
    I had to move my apple SSD to where the superdrive was, and my bootcamp SSD is where the old apple drive was, I believe it has something to do with the superdrive being Sata=0, and the drive was 1.. (could be wrong but think that is what I recall)

    Anyhow, once I did this I was able to boot from my mac SSD again, and bootcamp worked fine again.

    Although to get bootcamp installed I had to have the superdrive installed internally again, so I had to start the bootcamp assistant in mac, once it reboots to install windows shut down, remove the mac drive, install the windows drive and install windows, then remove the superdrive again and put the apple drive in the enclosure and the bootcamp drive where the apple one was and its working great now..

    found the answers via google when I was having issues.
     
  3. radof94 thread starter macrumors newbie

    Joined:
    Mar 27, 2012
    #3
    Thanks for the input, but I'm not sure if this applies to me. I don't have more than one internal hdd at any one time, and I have not switched out my superdrive for a hdd. I'm not using bootcamp either.
     

Share This Page