Easy Directions for 1.1.2 Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by macattack87, Nov 17, 2007.

  1. macattack87 macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #1
    Although you have to downgrade to 1.1.1 i found it alot easier then most websites make it seem to be. at the end you will have a jailbroken 1.1.2 iphone that works perfectly wll in everyway....here is my experiance with downgrading and hacking iphone 1.1.2: (THIS WILL ONLY WORK IF YOU HAVE A US PHONE THAT WAS UPGRADED TO 1.1.2) (FURTHERMORE YOU HAVE TO HAVE ACTIVATED IT ON AT&T USING ITUNES) (MUST USE ITUNES 7.4.2)

    Step 1- Download 1.1.1 software, make sure if its a .zip that you rename it so that it ends in _restore.ipsw

    Step 2- Download INdependence 1.2.5

    Step 3- Hold down the botton and the home button on your phone, when the screen goes black release the top button but continue to hold onto the bottom button.

    Step 4- Then connect your iPhone to iTunes. It should say you need to restore. Option Click on the restore button, a window will come up and select the 1.1.1 software you downloaded earlier.

    Step 5- Restore your iPhone, at the end it will error out, thats fine. Close iTunes and open INdependence, Dont click on anything just open it.

    Step 6- When your iphone gets the connect to iTunes when the activation screen comes up, Connect it and select to restore from back up when promted in iTunes.

    Step 7- Connect to wi-fi and go to jailbreakme.com, install apptapp

    Step 8- Install OtkoPrep and NOTHING ELSE

    Step 9- Connect to your computer and update to 1.1.2 via iTunes

    Step 10-Download the Concited Software package for finishing the 1.1.2 jailbreak

    Step 11- Open the folder, Click on Jailbreak.jar

    Step 12- After it runs, wait for your iphone to restart on its own, then restart it again. After you restart just leave it alone and it will restart on its own one more time.

    when it is done you have a jailbroken 1.1.2 iPhone

    Leave posts on here if you run into trouble, and i'll try to help you out

    IF YOU DAMAGE YOUR PHONE IT IS NOT MY PROBLEM, YOU ARE DOING THIS UNDER YOUR OWN RISK.
     
  2. DenniZ macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #2
    I used this technique on my MacPro 10.5 leopard with the beta version of independence and itunes 7.5, it took a couple attempts to kick it out of dfu mode but other than that it was plain sailing.
     
  3. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #3
    i didnt say anything about 10.5 because i didnt test it on there, however if it works it works
     
  4. Snide macrumors 6502a

    Snide

    Joined:
    Apr 12, 2005
    #4

    Hmmm. I have a Macbook, Leopard, iTunes 7.5, beta version of INdependence,
    and I can't get the iPhone out of DFU mode, period. So you're saying that
    INdependence fires up? For me, INdependence version 1.2.5 and beta 1.3b2
    crash on launch and will not run. Opening the INdependence MobDev tool shows this:

    [​IMG]

    -which is useless because even though I have the MobileDevice_7_4_2_Framework
    file (downloaded from Rapidshare), there's no way to select it using the tool.
    I even copied that file to System > Library > PrivateFrameworks; that didn't
    work either. In any event, most of the information about this stuff is cryptic
    at best, and I'm generally pretty good in the art of RTFM.

    Is there a newer beta version I missed somehow? Can you tell me the version you have?
     
  5. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #5
    again i never attempted this with iTunes 7.5
    thats why i wrote it was used with 7.4.2

    i suggest downgrading your iTunes to 7.4.2 or using another computer
     
  6. Sussman macrumors member

    Joined:
    Dec 9, 2006
    Location:
    Colorado
    #6
    Different computers question

    I was wondering... I accidentally upgraded iTunes to 7.5, but there is a mac at my school that still has 7.4.2. My question is will I be able to jailbreak a new iphone with the other computer but then use my own (with iTunes 7.5) to sync music, contacts, and stuff?
    Thanks in advance.
     
  7. bigandtasty macrumors 6502

    bigandtasty

    Joined:
    Dec 26, 2006
    #7
    no, I don't believe that will work (IMHO). You'll have to wipe it clean to upload your music from your home itunes if you put any tunes on the school comp onto your new iphone. Stock, the iphone will not let you associate with 2 different itunes.
     
  8. Lord Sandwich macrumors regular

    Joined:
    Apr 29, 2005
    #8
    For MobDev under iNdependence 1.3b, select the folder of the .framework after extraction, not any specific file. Worked fine for me just a few minutes ago. :)
     
  9. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
  10. Moleshome macrumors member

    Joined:
    Oct 22, 2007
    #10
    From the iNdependence readme file:

    ** INSTALLING INDEPENDENCE **

    Before you can run iNdependence for the first time, you must do the following:

    1) Copy iNdependence to your hard drive somewhere (the Applications folder would be a good place)
    2) Run the "iNdependence MobDev Tool" application. If it reports that you have the correct version of iTunes installed, then you simply need to choose the location where you installed iNdependence on your computer and you are done (skip the remaining steps).
    3) If it reports that you do not have the correct version of iTunes installed, then you'll need to find the version of the MobileDevice framework that was installed with iTunes 7.4.2 and put it somewhere on your computer. Something useful might be at:

    http://rapidshare.com/files/68410680/MobileDevice_7_4_2.framework.zip.html

    4) Once you have that, choose the location of the MobileDevice.framework folder using the first file chooser.
    5) If that works, then choose the location where you installed iNdependence on your computer using the second file chooser.
    6) At this point you should see a success message.

    If you do not successfully do this, then iNdependence will not run (it will show up in the dock quickly and then disappear). After you are done, then iNdependence will run without problems no matter what version of iTunes you upgrade to. You only need to do this once.
     
  11. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #11
    I was finally succesfull following the same method, but with the additional step of using AnySim 1.2.1u on firmware 1.1.1 to unlock my sim (I first needed to upgrade to 1.2.2 and then downgrade again).

    The hacktivation that the jailbreak.jar was supposed to do did not work for me. Cost me 2.5 hours yesterday to get it fixed !
     
  12. Lord Sandwich macrumors regular

    Joined:
    Apr 29, 2005
    #12
    Just a quick clarification: Step 10 refers to a Java app for your PC that you can get here.

    I didn't realize this and thought that it was also an iPhone package; when I updated to 1.1.2 and Installer.app vanished from the screen, I thought I'd done something wrong and restarted the whole process.

    The readme file also has the same instructions as the OP.
     
  13. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #13
    INdependence is not used for any reason other then to kick you out of DFU mode, YOU DONT CLICK ON ANYTHING IN INDEPENDENCE

    also, after u jailbreak 1.1.1 and upgrade to 1.1.2 installer.app WILL vanish
    THIS IS NORMAL

    after you run the java file in the concieted software package it will return
     
  14. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
  15. Snide macrumors 6502a

    Snide

    Joined:
    Apr 12, 2005
    #15
    The problem is that there is no folder. The file is zipped, and it opens, putting the file on the desktop.
    It can't be selected using the MobDev tool. I even created a new folder and put the file inside,
    but that didn't work either.

    What am I missing?
     
  16. Snide macrumors 6502a

    Snide

    Joined:
    Apr 12, 2005
    #16
    The problem is that INdependence won't launch (see my posts above).
     
  17. chacinelias macrumors newbie

    Joined:
    Sep 20, 2007
    #17
    Can't get kick my phone out of dfu mode!

    INdependence doesn't seem to be working...I did everything exactly like the instructions all over the web for downgrading and jailbreaking 1.1.2. I got the 1.1.1 ispw, iNdependence 1.2.5, iTunes 7.4, iPhone with firmware 1.1.2, Mac pro with Tiger.

    The iPhone has the "connect to itunes" icons on the screen and when i open iNdependence it just stays there. I've tried it about five or six times.

    Thanks in advance for your help.:)
     
  18. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #18
    to settle the INdependence issue.

    STOP USING ITUNES 7.5

    USE 7.4.2 AND NOTHING ELSE
     
  19. chacinelias macrumors newbie

    Joined:
    Sep 20, 2007
    #19
    Using 7.4!!!

    Im have:

    iTunes 7.4
    iNdependence 1.2.5
    Mac Pro w/Tiger

    iPhone doesn't come out of DFU mode when iNdependence is launched.

    Anybody else had this problem?
     
  20. chacinelias macrumors newbie

    Joined:
    Sep 20, 2007
    #20
    Nevermind People

    For those trying to kick iPhones out of DFU with iNdependence 1.2.5 IT DOESN'T WORK (or it didn't for me). USE 1.3 BETA.
     
  21. macattack87 thread starter macrumors member

    Joined:
    Nov 14, 2007
    Location:
    Jersey
    #21
    try to get your hands on itunes 7.4.2

    and i used INdependence 1.2.5 and it kicked my iphone out of dfu mode just fine
     
  22. Snide macrumors 6502a

    Snide

    Joined:
    Apr 12, 2005
    #22
    I used AppZapper to get rid of iTunes 7.5, and then installed 7.4.2. Still, I got
    the message (see post #4 above). The MobDev tool seems think I have 7.5...

    Believe me when I say that I spent many hours uninstalling, re-installing itunes, restoring, downgrading, ect,
    and have spent countless hours poring over hundreds of posts relating to this.

    Again - what am I missing?
     
  23. danwarne macrumors newbie

    Joined:
    Nov 20, 2007
    #23
    If you use the MobileDevice_7_4_2.framework file downloaded from Rapidshare, you need to rename it to MobileDevice.h before you try to select it using the Independence MobDev tool.

    Don't ask me why this crucial step isn't mentioned in the instructions... took me a lot of trial and error to figure it out. I finally figured it out by searching the Macintosh HD for "MobileDevice" and noticing that the one that is actually installed by iTunes is MobileDevice.h
     
  24. Lord Sandwich macrumors regular

    Joined:
    Apr 29, 2005
    #24
    I can't exactly remember where I got my copy as I'm still at work, but the zip file should create a folder with the .framework extension, not a file. This is what the tool is looking for.

    Check and see if a download link is in the iNdependence dmg's readme.
     
  25. Snide macrumors 6502a

    Snide

    Joined:
    Apr 12, 2005
    #25

    You sir, are a god! How in tarnation did you figure that out?????
    I renamed the MobileDevice_7_4_2.framework file to MobileDevice.h,
    and it magically turned into a folder. I was then able to navigate to this
    folder using MobDev tool, and selected it. Then I selected the INdependence
    app, and I got the following message:

    [​IMG]

    I then downgraded to 1.1.1 and used INdependence to kick it out of DFU mode.
    Now I'm back on 1.1.1 with all my favorite programs. Thanks so much!! :)
    Needless to say, it is very much possible to use iTunes 7.5, as I just did...

    Edit: I ran out of the house after restoring to 1.1.1 and syncing the iPhone.
    Only then did I realize that the iPhone was not connecting to the ATT network.
    The only way to get it onto the network was to restore to 1.1.2.
    So I once again reverted to 1.1.1, and followed all of the steps in the original post
    of this thread. It is now on 1.1.2, Jailbroken, and activated on ATT network.

    Thanks to macattack87 for putting the guide together, and very special thanks
    to danwarne for figuring out the mystery of the MobileDevice.h folder.

    You can rest assured that I'm going to need a very good reason to "upgrade" from 1.1.2...
     

Share This Page