Easy one (I hope) for the Pro's

Discussion in 'macOS' started by systematic92, Aug 12, 2016.

  1. systematic92 macrumors newbie

    Joined:
    Dec 27, 2015
    #1
    Guys,

    I have a 2010 MAC that came with OSX 10.7.

    The hard drive died and I had a spare one lying around. The spare had a version of Windows 7 on it but I proceeded to psychically replace it - all good.

    I booted up to internet recovery, went into Disk Utility and saw the Crucial SSD in the left. I proceeded to select the top left hard drive and erase it using OSX (extended journaled) - all good.

    I went back to install OSX Lion. It downloaded, allowed me to continue and here is where my nightmare begins.

    So I was looking at the installation logs each of the 3 times I attempted the install and it hung after completing chunk 449 of 449. Nothing happened after that - no reboot, nothing. So I waited 1 hour, tried again, same thing, waited 2 hours, same again (stuck at same point) and tried again.

    The 3rd time I have had success in that the system has in fact restarted after retrieving the last chunk.

    Now I am at a white window, grey apple logo and spinning circle below it.

    Any idea wtf is happening here please?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    From your description it does sound like either RAM or graphics might be on the way out.

    Please could you confirm what model of Mac you have? Year/spec/size etc.
     
  3. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #3
    Thanks for the quick response man. it sounds like something is screwed but there's no easy way for me to verify it....or is there?


    MacBook Pro (13-inch Late 2011) MODEL A1278
    2.4ghz
    4GB RAM
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    RAM problems is a good possibility, too. Try reseating your RAM sticks (swap the sticks between the slots). Seat/unseat/reseat a couple of times to make sure that the sticks are fully seated.
    (If you get this working, upgrading the RAM is a good thing to do, too! You can upgrade to as much as 16GB max.)

    Boot again to internet recovery.
    Disk Utility, select the SSD (not the line underneath with the name of your partition), then click the Partition tab.
    choose "1 partition" from the drop down menu, then name the partition, if you like.
    Click the Options button, and make sure that "GUID" is selected, and NOT "Master Boot Record" (MBR), which would be left-over from the Win7 install. Click OK, then Click "Apply". That will only take a few seconds to complete.
    As a habit, I usually will shut down my Mac, so the power goes off completely. You shouldn't need to do that shut down, but it's just something that I do almost every time that I replace hard drives. Then, boot up to Internet Recovery, and try the OS X install.
     
  5. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #5
    Just doing another erase and see what happens. If I get stuck at logo and spinner, ill try as you suggested.

    Ill reseat the RAM if this install stalls.
     
  6. NT1440 macrumors G4

    NT1440

    Joined:
    May 18, 2008
    Location:
    Hartford, CT
    #6
    Always start with a PRAM/NVRAM reset for good measure when having boot issues:

    https://support.apple.com/en-us/HT204063

    You'd be shocked how often it fixes the problem. I always let the machine chime 4 times for good measure (meaning continue holding down the keys until you hear the 4th chime).
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    Did you check for GUID or MBR first?
    The PRAM/NVRAM reset is also a great idea! I let the chime sound for at least 2 times, and no harm with holding for more chimes. There was (years ago, before the new world ROMs in Macs) good technical reasoning to let the boot chime sound 5 times before releasing the boot keys, but I haven't heard about that for a long time now.
     
  8. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #8
    I did the PRAM 2 times earlier and it did bugger all.

    My 4th installation is close to finishing so ill try all the goodies thereafter. Not too sure where this issue lies.
    --- Post Merged, Aug 12, 2016 ---
    Delta - gonna do that right after this install finishes.
    --- Post Merged, Aug 12, 2016 ---
    Install went through fine and MACBOOK rebooted. Now back on the White Screen/Apple Logo/Spinning Dial

    Will leave for about an hour and if nothing happens. Ill force shutdown via button, reseat RAM and power to IR for GUID checks
     
  9. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #9
    --- Post Merged, Aug 13, 2016 ---
    OK didn't get a chance to do this yesterday but having a stab now.

    I've followed ur advice delta. I created the GUID partition. It was set to this by default as opposed to MBR.

    I powered down immediately after and removed the ram in slot one and two (2 x 2gb) and reinserted just one 2gb stick on slot one.

    I've now booted to Internet Recovery and trying a fresh install of 10.7 lion.

    If this doesn't work. Any further suggestions?

    Results to follow shortly.
     
  10. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Suggestions and thoughts, in no particular order:
    Download the 10.7 installer from another Mac, and create a bootable flash drive with the Lion install.
    There's no real reason to stick with Lion, as the 2011 can run any OS X system from 10.7 to current version.
    Try a different drive. It sounds like you are assuming that the SSD is good, and you might be incorrect :D The install problems might indicate that your SSD is just no good.

    Those MBPros can have drive problems, when the real culprit is the SATA drive cable. You will want to try replacing that cable, if nothing else helps.

    Also, an hour or so may seem like a long time, or not... Give the install a bit more time to finish. For example, start the install and leave for lunch, or let it run overnight, etc. (the long install time can ALSO be another symptom of a failing drive.)
    Now that you have seen that half the RAM does not help, put it all back in place, or even better, upgrade the RAM
     
  11. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #11
    Ok so same crap happened. System reboots to spinning wheel.

    I decided to do a verbose boot using COMMAND V and the system always halted at AHCIDISKQUEUEMANAGER timed out or something to that effect.

    Add that to the fact when you go into recovery mode after a fresh install, there is no startup disk to select.

    I think the SSD is goosed.

    The weird thing is the S.M.A.R.T status of the drive is fine.

    Another reason I say the drive is goosed is because I replaced the SSD with a MAC HDD from another MAC i own and it booted fine......The only difference is that the HDD I inserted in the MAC has EL CAPITAN on it and not Lion.

    So my suspicions are that the HDD is crapped OR its not compatible with the MBPro OR OSX Lion is not playing ball???

    What you think?
     
  12. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    I think you need to try a different SATA cable.
    It's quite common to see reports where a spinning hard drive works, but an SSD will fail, showing a variety of issues, because of a faulty SATA cable. It seems to have something to do with timing issues.
    Spinning hard drive works fine, SSD - not so good.
     
  13. systematic92 thread starter macrumors newbie

    Joined:
    Dec 27, 2015
    #13
    I've just ordered another SSD via prime now. If this gets goosed then on to a new Sata can it is
    --- Post Merged, Aug 13, 2016 ---
    If the cable is faulty which one do I buy?
     
  14. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #14

Share This Page