Easy-PhotoPrint EX quits unexpectedly

Discussion in 'Mac Basics and Help' started by Blakadher, Apr 26, 2010.

  1. Blakadher macrumors newbie

    Joined:
    Sep 10, 2009
    #1
    I have been using Easy-PhotoPrint EX for quite some time, but recently when I go to try to open it I get the quit unexpectedly dialog. If I boot into safe mode it runs fine. I have tried uninstalling and reinstalling a couple times now (I made sure I'm running the most recent version available from Canon's website), but it continues to quit unexpectedly. I use AppCleaner to remove it, but maybe AppCleaner is not removing everything and there is some file being left behind that is keeping it from running properly? Any help or suggestions you can provide will be greatly appreciated. Thanks!

    UPDATE:
    I figured out what the issue was. I looked a little closer at the crash log and saw that it was crashing on libTrueTypeScaler.dylib. This jogged my memory that I had added some fonts about a month ago. I started disabling them one by one and found that when "Franklin Gothic Book" is enabled Easy PhotoPrint EX won't start. After disabling that font everything is fine. Maybe this will help someone else in the future.
     
  2. Zicomeg macrumors newbie

    Joined:
    Jun 21, 2010
    #2
    Same problem here

    Had exactly the same issue. Solution worked for me too.
    Thanks a lot!
     
  3. ahuss macrumors newbie

    Joined:
    Jan 6, 2015
    #3
    I had the same issue when i used this program for the very first time on MAC OS x 10.7.5. Your solution was very helpful in identifying the offending fonts. For me they were shown like this in the log.

    VM Regions Near 0x8712944:
    mapped file 0000000007e3d000-000000000837c000 [ 5372K] r--/rwx SM=COW /Library/Fonts/AdobeFanHeitiStd-Bold.otf
    --> mapped file 000000000837c000-000000000875b000 [ 3964K] r--/rwx SM=COW /Library/Fonts/AdobeMyungjoStd-Medium.otf
    CG image 0000000008942000-0000000008953000 [ 68K] rw-/rwx SM=PRV

    I disabled them and got the program runnind which was good. However later on when I tried to use Adobe CS5 Fire Works, it complained about these two fonts as they work under adobe fonts.

    Thanks for your help anyway.
     

Share This Page