Edit ACL in Snow Leopard

Discussion in 'Mac Basics and Help' started by Cor anglais 16, Jul 16, 2010.

  1. Cor anglais 16 macrumors newbie

    Joined:
    Jan 7, 2010
    #1
    I am basically trying to do the trick with iPhoto described here: http://www.macosxhints.com/article.php?story=20050904072808460&lsrc=osxh. However, I'm running Snow Leopard, which has disabled fsaclctl; but access control lists (ACL) supposedly have been enabled across the board with no way to turn them off. That part's just fine with me, but I can't seem to find anything that will allow me to add or edit them, which is what I need to do. Sandbox keeps returning an "Operation not supported" error. I even tried the trick here: http://forums.macosxhints.com/showthread.php?t=105879, which suggests copying fsaclctl from a Leopard system into my Snow Leopard system. Terminal still returns the same "Access control lists are not supported or currently disabled on /.", even when I run fsaclctl -a / -e. I don't have a 10.5 system available, so I copied fsaclctl from my old 10.4 system; I don't know if that has something to do with it (fsaclctl -v returns version 1.1). I tried looking for a more up-to-date fsaclctl somewhere online and I can't seem to find anyplace that has it for download. Anyone have any ideas?
     
  2. Cor anglais 16 thread starter macrumors newbie

    Joined:
    Jan 7, 2010
    #3
    Yeah, but the downside is that the disk image needs to be constantly mounted and unmounted. The ACL trick is a seamless solution for this sort of situation where two accounts are adding information to a shared file; I just can't believe that Apple would have completely wiped out such a low-level UNIX function as access control lists (it's still in Server, I think).
     
  3. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    What about the Shared folder the second link talks about?
     
  4. Cor anglais 16 thread starter macrumors newbie

    Joined:
    Jan 7, 2010
    #5
    Yes indeed, I'm actually using the Shared folder for this, but only because it's a location both accounts can access. Even when permissions are set on the iPhoto Library (or recursively on a folder in the Shared folder that contains the iPhoto Library) to allow everyone read and write access, OS X still makes additions to that file (e.g., photos added from one account) subservient to the person who added them. That is, though both accounts have complete read and write access, if one account adds some photos, that account is flagged as the owner of those photos and the other account technically and practically does not have access to them. Specifically, in iPhoto's case this means the thumbnail permissions are messed up, and the only way to fix it is to open iPhoto while holding command-option and repairing the thumbnail permissions. Takes almost no time to do, but it's not seamless or Mac-like to have to do it (we Mac users are a persnickety bunch, aren't we?). ACL was a great workaround for this on my 10.4 machine. Note this doesn't work with iTunes; Apple seems to have wired iTunes to ignore ACL, probably for reasons of preventing potential illegal file-sharing. I can't seem to find where I read all this information the first time (there have been a lot of web searches in the last day or so trying to solve this problem), or I would link it here. At any rate, that's where I'm standing, and ACLs seem to be the only solution, except 10.6 doesn't want to let me edit them.
     
  5. Cor anglais 16 thread starter macrumors newbie

    Joined:
    Jan 7, 2010
    #6

Share This Page