Editing a locked folder

Discussion in 'Mac Basics and Help' started by Klymene, Aug 20, 2013.

  1. Klymene macrumors newbie

    Joined:
    Aug 20, 2013
    #1
    Hi, I'm trying to edit a folder and cant seem to get it unlocked. I have tried unlocking it in the "Get Info" window, but it just re-locks itself. I have also tried "sudo chflags nouchg", but after I type in my password it says that it's a read-only file system. Any other ideas on how to unlock it? Thanks in advance. :)
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    What is the filepath of the folder? What files are you trying to edit?

    If you are comfortable with the Terminal, then you might want to use chmod to allow reading to the folder and its contents.
    Note that you will need to change this back after editing. There's usually a reason for files to have the attributes that they do.

    Something like "sudo chmod -R a+r foldername" may work.
     
  3. Klymene, Aug 20, 2013
    Last edited: Aug 20, 2013

    Klymene thread starter macrumors newbie

    Joined:
    Aug 20, 2013
    #3
    Its file path is /Volumes/Toribash/Toribash/, It's a game. I'm trying to change and image file in it. I'm not sure what I would do with chmod, I don't use terminal very much, but I'll try the other one. :D
    ---
    Edit: Oh, that's what you do with chmod. :p

    ----------

    I tried the thing with chmod but it didn't even return anything. :confused:
     

Share This Page