Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

nunes013

macrumors 65816
Original poster
May 24, 2010
1,284
185
Connecticut
Hi everyone. I enabled HomeKit on my eero router and beacons. I noticed last night that my Ecobee’s would connect to the router, but not Ecobee’s servers. I tried power cycling, resetting the network, etc and nothing worked. Finally today I turned off HomeKit on the eeros and the Ecobee’s were able to connect again. Does anyone with eero have this problem with Ecobee or any other HomeKit devices?
 

bbednarz

macrumors 65816
Nov 16, 2017
1,410
3,740
Chicago
Did you have it set as restricted? I set all of my stuff to 'restricted' as a test to see what actually needed to talk to the outside. Found out quickly that the Ecobee needs to be set to 'auto'. Once I changed it to 'auto' everything worked again.
 

Itinj24

Contributor
Nov 8, 2017
4,492
2,575
New York
I left mine on Auto and haven’t seen an issue but I didn’t try any other modes with the Ecobee.

Also I believe I read that if you disable HomeKit Routers from the Eero’s, it’s permanent.
 

nunes013

macrumors 65816
Original poster
May 24, 2010
1,284
185
Connecticut
Did you have it set as restricted? I set all of my stuff to 'restricted' as a test to see what actually needed to talk to the outside. Found out quickly that the Ecobee needs to be set to 'auto'. Once I changed it to 'auto' everything worked again.
I left mine on Auto and haven’t seen an issue but I didn’t try any other modes with the Ecobee.

Also I believe I read that if you disable HomeKit Routers from the Eero’s, it’s permanent.
Thank you! I will set to Auto and see.
[automerge]1583720940[/automerge]
Just tried it and everything is good so far! Thanks!
 
Last edited:
  • Like
Reactions: Itinj24

nathan.l.larsen

macrumors member
Apr 22, 2014
36
47
I just ran into this issue with my ecobee 4 thermostat & eero Pro system with HomeKit enabled and Accessory Security set to Auto for ecobee Inc. Thermostat in the Home app. I was experiencing the issue where it would connect to my wifi network, but not ever connect to ecobee servers. I went through every possible troubleshooting step on my own, and then with ecobee support, whose did show that it could connect to their servers when connected using my phone's hotspot, isolating the issue to my eero Pro network. Their proposed solution was to completely reset my wifi network (uh, no). After they said "Contact eero or your ISP," I did some more digging on ecobee's wifi settings, and it looked like they recommend allowing two ports in your eero settings. Here's how to do that:

Go into the eero app, tap Settings at the bottom, then Network settings, then Reservations and port forwarding. Tap "Add a firewall rule" under the IPv6 Firewall Rules heading. Select your thermostat from the list of devices currently on your network. Mine was named "Living Room," and once you've selected it, tap "Add a firewall rule" at the bottom. Then, add ports 8089 & 8190 one at a time to the box. Here's the documentation from ecobee: https://support.ecobee.com/hc/en-us/articles/227873287-Connecting-to-the-Internet

Hopefully that helps everyone else! Feel free to ask any questions if needed!
 
  • Like
Reactions: Itinj24

AustinFlack

macrumors newbie
Jan 23, 2023
1
0
I just ran into this issue with my ecobee 4 thermostat & eero Pro system with HomeKit enabled and Accessory Security set to Auto for ecobee Inc. Thermostat in the Home app. I was experiencing the issue where it would connect to my wifi network, but not ever connect to ecobee servers. I went through every possible troubleshooting step on my own, and then with ecobee support, whose did show that it could connect to their servers when connected using my phone's hotspot, isolating the issue to my eero Pro network. Their proposed solution was to completely reset my wifi network (uh, no). After they said "Contact eero or your ISP," I did some more digging on ecobee's wifi settings, and it looked like they recommend allowing two ports in your eero settings. Here's how to do that:

Go into the eero app, tap Settings at the bottom, then Network settings, then Reservations and port forwarding. Tap "Add a firewall rule" under the IPv6 Firewall Rules heading. Select your thermostat from the list of devices currently on your network. Mine was named "Living Room," and once you've selected it, tap "Add a firewall rule" at the bottom. Then, add ports 8089 & 8190 one at a time to the box. Here's the documentation from ecobee: https://support.ecobee.com/hc/en-us/articles/227873287-Connecting-to-the-Internet

Hopefully that helps everyone else! Feel free to ask any questions if needed!
Thank you so much for this comment! I was tearing my hair out!
 

nathan.l.larsen

macrumors member
Apr 22, 2014
36
47
Thank you so much for this comment! I was tearing my hair out!
No problem! Ironically, I just had an issue yesterday with my ecobee where I could access it in the app, but not in the Home app. It would give me the notice that the thermostat and it's sensors gave "No Response." ecobee Support had me temporarily pause my eero 5GHz network, as well as set the Homekit Accessory Security to "No Restriction." The combination of the two allowed me to resolve the No Response error in the Home app. Hope that helps someone as well!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.