Effed up my OS again...

Discussion in 'Mac Pro' started by NEUengineer, Oct 28, 2010.

  1. NEUengineer macrumors member

    Joined:
    Feb 11, 2010
    #1
    Long story short:
    New SSD, works great
    Old HD with os on it in bay 2
    Accidentally hit (apply to enclosed) when adding my new account to os and now have custom permissions on my old HD.
    Cannot access old HD
    cannot use disk utility to repair permissions

    How do i fix this?
     
  2. diazj3 macrumors 6502a

    Joined:
    Jan 19, 2008
    #2
    what set of permissions did you accidentally applied?
    Have you tried booting from the install disk and using disk utility?

    Perhaps installing OS and trying to migrate/import from old HD?
     
  3. NEUengineer thread starter macrumors member

    Joined:
    Feb 11, 2010
    #3
    I had an error migrating all my old files. basically i had one file that was incompatable so i had to migrate all the user data, and then go back for the apps and other files. I had to generate a new account to migrate everything properly. I deleted my original account since i could not move my files to it. That was the problem. now my drives had permissions set to an account that was deleted. I gave my new account admin stats and then all hell broke loose. Tried booting from the disk. repaid permissions, but some could not be fixed. could not reinstall os, got an error. Disk is fine though since i used it on my laptop. all drives have a locked symbol
     
  4. cutterman macrumors regular

    Joined:
    Apr 27, 2010
    #4
    Try logging in as 'root' and resetting permissions.

    Here is a link on how to enable 'root' user.
     
  5. NEUengineer thread starter macrumors member

    Joined:
    Feb 11, 2010
  6. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #6

    Attached Files:

  7. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #7
    I'd try BatChmod. I've used it in the past to fix permissions.
     

Share This Page