EFI 1.7 Firmware Update Slows Down Stock Hard Drive - Reset Your PRAM

Discussion in 'MacBook Pro' started by Smoothie, Jun 24, 2009.

  1. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #1
    My stock Hitachi 250 GB hard drive's sequential write speed appears to be significantly degraded since the EFI 1.7 firmware update that Apple rolled out yesterday. I've run the test several times, and the results are consistent. Here are the Xbench scores, with pre-upgrade on the left:
     

    Attached Files:

  2. Smoothie thread starter macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #2
    I just did a PRAM reset, and it seems to have fixed the slow speed. The speeds now match the pre-upgrade speeds. I should have tried this before posting.
     
  3. Higgs1 macrumors 6502

    Higgs1

    Joined:
    Jun 6, 2009
    Location:
    Boston, MA
    #3
    i seemed to be getting slower speeds on my HD too after the update (mine is an aftermarket Seagate 500gb though) and after resetting the PRAM it seems back to normal!

    Thanks for the heads up as i forgot about trying to reset it
     
  4. cababah macrumors 68000

    Joined:
    Jun 11, 2009
    Location:
    SF Bay Area, CA
    #4
    I also have the stock 250GB HDD...I did not do any benchmark tests, but is there any downside to resetting the PRAM if it is not necessary?

    I am not noticing anything wrong in my day-to-day tasks..
     
  5. Smoothie thread starter macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #5
    I don't think that resetting the PRAM can do any harm. In my case, I didn't really notice the slower speeds. But there were a number of posts from people who had noticeable problems after the firmware update, so I decided to measure my speeds. That's when I saw the slower write speed.
     
  6. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
    #6
    I've run quite a bit of XBenches after the EFI 1.7 fw upgrade, I can notice a very slight decrease in disk performance. Nothing noticeable in real usage (which is what real matters, not a synthetic benchmark), but the slight decrease is there....

    What matters to me, is the future proofing, and the fact that putting an SSD in, would not yield capped transfer speeds. :)

    Resetting the PRAM didn't do much for me.
     
  7. fixmdude macrumors member

    Joined:
    May 8, 2009
    #7
    My stock 250 GB dropped from

    80 Write / 81 Read - before the update to

    60 Write / 80 Read - after the update.

    I restarted and held down "Option - Command - P - R" until it bonged a second time to reset the PRAM and it's back to its original speeds again.

    I have a 500 GB WD Blue on the way.
     
  8. HFU macrumors regular

    Joined:
    Jun 8, 2005
    #8
    My stock 250GB (Hitachi HD) also dropped slightly after firmware update. The result showed consistently under xBench. Reset PRAM still showed the same dropped score. It can't never reached the 80MB/s+ sequential write as pre-firmware update.

    Although it's synthetics benchmark which probably does not affect real world performance much, I'm also interested to know performance result from people with Hitachi/Seagate/WD 7K SATA 3.0Gb/s drive. Some people have reported SSD SATA 3.0Gb/s drives have experienced problems after firmware update, I wonder if the 7K SATA 3.0Gb/s mechanical HD also experience this performance slow down?

    http://discussions.apple.com/thread.jspa?threadID=2054387&tstart=0
     
  9. zsnow macrumors regular

    Joined:
    Mar 15, 2009
    #9
    you should run several xbench several times before you update fw.
    I found xbench result are not consistent at all.
     
  10. Diode macrumors 68020

    Diode

    Joined:
    Apr 15, 2004
    Location:
    Washington DC
    #10
    Resetting the PRAM seemed to fix my beach ball issues with the stock drive.
     
  11. glavoie84 macrumors regular

    Joined:
    Jun 23, 2009
    #11
    Here it didn't help! I get a beach ball with while doing almost nothing (browsing the web) from time to time and my browser freezes for about 20-30 seconds every times. Actually, it happens with any application.
     
  12. jlamarp macrumors newbie

    Joined:
    Apr 13, 2009
    #12
    I ran into this problem after updating to the EFI 1.7 firmware with my WD 500GB HDD. Resetting the PRAM didn't help, calling Apple technical support didn't help, going to the Apple store and having them look over the laptop for an hour didn't help.

    I ended up having to put the stock 250GB HDD back into the Macbook Pro.

    Now I am unable to use my WD 500GB HDD that worked perfectly fine before the firmware upgrade.

    I wish there were a way to back out the firmware upgrade, but according to everyone I've spoken with, there isn't.

    Hopefully Apple resolves this issue soon...
     
  13. MBP09 macrumors member

    Joined:
    Jun 9, 2009
    #13
    How about restoring your Mac back to factory then unchecking the update....
     
  14. elschus macrumors newbie

    elschus

    Joined:
    Oct 30, 2007
    #14
    See the post by Dave2412 on page 3 of this thread for a possible(?) solution:

    http://discussions.apple.com/thread.jspa?threadID=2054387&tstart=0&messageID=9707619#9707619

    Good luck!
     
  15. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #15
  16. RED™ macrumors regular

    RED™

    Joined:
    Nov 18, 2008
    Location:
    Near German Black Forest
    #16
    It doesn't matter if I "only" have the 160 GB drive to run the PRAM, right?
     

Share This Page