EFI Firmware 1.7 causing problems?

Discussion in 'iMac' started by zeussz, Oct 31, 2011.

  1. zeussz macrumors newbie

    Joined:
    Oct 19, 2011
    #1
    Hi everyone

    Today I installed the iMac EFI Firmware update 1.7, supposed to address issues with TB ports and also Lion internet recovery.

    Also today I have had nothing but crashes. Kernel panics. My iMac has been completely fine until now, but now it's kernel panic every time I try to open up my latest project in Logic.

    Anyone else having any problems since the 1.7 EFI update, or the Thunderbolt Software Update 1.1 that came with it?

    I just don't know what else could be the problem. My machine is currently unusable.

    The other troubling thing, is that the 1.7 update page says the
    Boot ROM Version should be IM121.88Z.0047.B1D.1110171110

    but mine is reading
    Boot ROM Version: IM121.0047.B1D

    I see it's similar, but it does not have all of the #s... does this mean the update did not finish correctly?
     
  2. SDRacerR1 macrumors member

    Joined:
    Aug 28, 2009
    #2
    Ya I am gonna call Apple tomorrow. Never had the "wake from sleep" Wifi issue...now I do;

    Also, my iMac is a lot louder. Not sure if its the fans or the hd spinning faster, but used to be silent...now a low humming can be heard.

    Thought these were fixes...not introducing new problems...
     
  3. zeussz thread starter macrumors newbie

    Joined:
    Oct 19, 2011
    #3
    Something else that only started happening today.

    My headphones became a microphone.

    From the headphone-out jack on the iMac, I have a splitter that splits the signal to 1) studio monitors 2) headphones. I always have both plugged in and powered on and listen accordingly.

    Today after the update, I noticed that when I bumped the headphones, I heard it on the studio monitors. I then spoke into the headphones, and heard my voice amplified coming out of the studio monitors.

    Any idea how this can happen, other than something is very messed up with this firmware update?
     
  4. BarkingGhost macrumors regular

    Joined:
    Oct 18, 2011
    Location:
    Atlanta+35 miles
    #4
    Can you elaborate on this? I've done complete updates (including both EFI updates) on a brand new iMac and last night I got 'Wi-Fi: No hardware found' after shutting down and starting up. I ran AHT twice (love the smoke and mirrors and wonder if anything really happens) and it worked again, but I haven't turned on the iMac this morning yet.
     
  5. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    All Good Here

    On imac, MBP and MBA. They did stagger the release though. Only Apple can help with this one EFI is effectively your BIOS not to be played with without support.
     
  6. muvaphuka macrumors newbie

    Joined:
    Sep 16, 2010
    #6
    Don't know if its coincidence, but the screen on my 27 inch 2011 iMac has developed a brightness flicker in the last few days (updated firmware the day it came out).

    It seems to be just the left half of the screen dimming though, so suspect its a hardware fault.......a trip to the Apple genius bar soon i suspect.
     
  7. pewra macrumors regular

    pewra

    Joined:
    Jun 26, 2011
    #7
    Unplug it from the iMac and repeat the speaking. It'll still happen.

    Nothing to do with the firmware.
     
  8. malias4 macrumors 6502

    malias4

    Joined:
    Jun 21, 2011
    Location:
    Greece and Holland
    #8
    is it also for imacs or only macbook ?
    i dont have an update yet :confused:
     
  9. dborod macrumors member

    Joined:
    Jul 22, 2002
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I'm experiencing an issue with my external monitor (24" Dell) coming out of screen saver. Both screens flash blue and then items that were on the second screen are back on the first screen. Time to call a genius.
     
  10. CWallace macrumors 603

    CWallace

    Joined:
    Aug 17, 2007
    Location:
    Seattle, WA
    #10
    My Boot ROM is also IM121.0047.B1D and no problems on the iMac. The TBD update also seems to have fixed an infrequent issue where my attached ATD would go black for a moment.
     
  11. BarkingGhost macrumors regular

    Joined:
    Oct 18, 2011
    Location:
    Atlanta+35 miles
    #11
    I returned the i7Mac I purchased last Friday. The folks in the Apple could not explain what I demonstrated the cold boot issues (choppy video, no wifi hardware being reported, USB devices not be autodetected, menu bar not loading). They ran diagnostics on it and gave up.

    Before making the return, I did a clean install of Lion, but I could not un-do the EFI updates. Issue remained. So, the store swapped out and had me set up the new unit today in the store. I performed no updates and only create the initial user account.

    All seemed fine, including accessing the store's wifi, until I shut the unit down and cold booted it again. The two Genius' (Genii?) just stood there like a deer in the road with this iMac's headlights starting them down. Same issues.

    So, their only options were a) I keep the second unit and live with it, or b) return it for refund. I took the refund. Also, there were two other folks in their with their recently purchased iMac's also having issues. I spoke to both of them, and they were not happy either. One of them was on his 3rd replacement unit. :eek:
     
  12. dricon macrumors newbie

    Joined:
    Nov 1, 2011
    #12
    Color looks completely messed up on my 24" iMac since I installed this update. (blues and greens especially weird looking).

    Is there a way to go back to 1.6?
     
  13. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #13
    Nope. Try calibration?
     
  14. Mac Eagle macrumors member

    Joined:
    May 5, 2010
    #14
    Frustrated


    I've had my 27" i7 3.4 iMac since mid June. It has been mostly stable except for some dropped wi-fi connections with aTV that were annoying (internet would still work and was still connected to wireless router (airport extreme)). However, on the day iOS 5 was released I suddenly started losing my wireless connection altogether (no wireless routers found at all and sometimes "no airport hardware installed message"). I actually had my local Apple Store replace the airport card but the issue continued (that whole experience is for another thread :( ).

    Looking back I remembered that in order to prepare for iOS 5 I had updated my system from 10.6.7 to 10.6.8 and updated itunes and Safari as well. I could reproduce the error by logging into my account and into a "clean" guest account. I also had tried loading back into a clean install of 10.6.7 on a external drive and I did not have the issue there (letting the machine run constantly for 8-9 hours). Typically it would drop after just a few hours max.

    I finally bit the bullet and, thinking it may be 10.6.8 related, upgraded to Lion. It at first seemed stable (about 5 hours) but then last night it went out again. I was thinking that maybe since I upgraded Lion and didn't do a clean install that I brought the software issue along with it. However, I once again booted up my system using my clean (absolutely nothing else loaded on it) 10.6.7 system and let it run over night. I woke up this morning and sure enough the wi-fi was gone. So at this point I can only assume that there is a hardware defect somewhere (maybe thermal related or something).

    So anyway, I don't think the wireless drop issues are related to the new EFI, which I didn't have installed when this issue started. I am going to call Apple Care tonight and see if I can get a new machine (BTO) as I hate to play "part-swap-roulette" trying to resolve this issue in a machine that is just over 4 months old.
     
  15. jmlaprise macrumors newbie

    Joined:
    Nov 25, 2011
    #15
    I too applied the EFI firmware update, followed by the SMC firmware update, and my MacBook Pro has been giving me nothing but problems since.
    The fans are always going into 4500+rpm when I am hardly running anything at all, the CPU on my Parallels VMs are always going into 100% CPU (before they even boot up).
    My MacBook Pro was running perfectly up until this point. Now I have to listen to a laptop that sounds like a jet taking off. I hope they provide an update for the update soon.
     

Share This Page