(Efi/FW) is it normal? MacBook Pro 2016

Discussion in 'MacBook Pro' started by Calby, Mar 4, 2017.

  1. Calby, Mar 4, 2017
    Last edited: Mar 4, 2017

    Calby macrumors 6502

    Calby

    Joined:
    Dec 30, 2015
    Location:
    Sweden, Gävle
    #1
    Hi,
    Directly when I did open my new MacBook Pro 13" 2016 made November 2016 I did put a USB-drive with 10.12.3 on it and did a clean install from it.
    I did not even start it first, clean install right away.

    During the final steps of the installation when it's black background with a Apple logo and a progressbar and during that the MacBook did restart and then under/before the restart I did see som writing on the screen very fast like for just 1sec (white text on black background), like when a old pc starts with bios.
    And then it did restart and I did hear the sound like when you do attach the charger and then it did start back right on the spot were it did restart. On the same spot and same progress in the progressbar.

    I did try to reinstall macOS again to see if the same thing did happen but it did not, so that's why I'm wondering if it's some EFI or Firmware that was installed.
    I have never seen this behavior before, but I have never really watched the hole installation before either, I have been doing clean install on like six other MacBook pros 2016 before this one.

    So my question is, is it any new EFI or Firmware update for it that did update during my installation of 10.12.3?
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    Yes, 10.12.3 contained firmware updates for many Macs.
     
  3. Calby thread starter macrumors 6502

    Calby

    Joined:
    Dec 30, 2015
    Location:
    Sweden, Gävle
    #3
    Okej good, that explaines it I guess?. Then it was because of the EFI or Firmware update?
    As the charger sound did sound came direct when it's restarted my guess is that it did update EFI or Firmware and that's why it sounded as it "reseted" it as the charger Depands on SMC.

    Or do you think it's some kind of issue?
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    There's no problem.
     
  5. Calby thread starter macrumors 6502

    Calby

    Joined:
    Dec 30, 2015
    Location:
    Sweden, Gävle
    #5
    Thanks sounds good!
     

Share This Page