eject disk image from finder?

Discussion in 'OS X Mountain Lion (10.8)' started by irishloveguines, Jul 25, 2012.

  1. irishloveguines macrumors member

    Joined:
    Jan 14, 2011
    #1
    For some odd reason, I can't seem to eject any disk images I mount. I'm on ML 12A269. Is this a bug? How do I fix it? The only way I can eject a disk is by restarting my MBA (2011 i7)
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Have you tried relaunching Finder instead of restarting? Have you made sure nothing is accessing the .dmg at the time you try to eject it?
     
  3. irishloveguines thread starter macrumors member

    Joined:
    Jan 14, 2011
    #3
    Yes, but I still can't get my .dmg to eject from the desktop :( Is anyone else having this problem? Is it because I'm on the GM and not the Appstore release?
     
  4. AngerDanger macrumors 68030

    AngerDanger

    Joined:
    Dec 9, 2008
    #4
    Stupid question: have you tried ejecting with Disk Utility?
     
  5. WRP macrumors 6502a

    Joined:
    Jul 20, 2011
    Location:
    Boston
    #5
    Even stupider question... is the installer still running?
     
  6. irishloveguines thread starter macrumors member

    Joined:
    Jan 14, 2011
    #6
    If I try Disk Utility, the .dmg will eject, however from the Finder sidebar, or dragging the .dmg from the desktop to the trashcan - fails. :(
     
  7. steviet macrumors newbie

    steviet

    Joined:
    May 27, 2016
    #7
    i have the exact same problem and was really hoping there was an answer here. Only difference is that i'm using Mavericks.
     

Share This Page