Eject key / "drag to eject" not functioning at all

Discussion in 'Mac Pro' started by MatchFrame, Apr 22, 2009.

  1. MatchFrame macrumors member

    Joined:
    May 2, 2008
    Location:
    Dallas, TX
    #1
    Out of the blue, the eject key on my keyboard produces no results whatsoever. Also, pressing the eject button in Finder does not work, and dragging a disc to the trash does not eject it, either (it does change the trash can to the eject symbol, though). The specs for my mac pro are in my signature (Early 2008 2.8).

    I looked up a terminal commands to this, and found the following, all of which work on my Mac Pro:

    drutil tray eject
    drutil tray close
    drutil tray open

    I made AppleScripts for those, all of which work every time, no problem. Audio CD's eject from iTunes when pressing the eject button within iTunes as well.

    I have a workaround, but I want everything back to normal. Do you know of any solutions to restore functionality to the eject button on the keyboard, within Finder, and dragging discs to the trash?
     
  2. rylin macrumors 6502

    Joined:
    Aug 18, 2006
    #2
    What do the logfiles say when you try to eject a disc the normal way?
    (You can see the logs by running /Applications/Utilities/Console.app )
     
  3. nicolasmasset macrumors regular

    Joined:
    May 25, 2007
    Location:
    Belgium
    #3
    I've had that a LOT on my macbook. OSX does some wierd things sometimes.
     
  4. MatchFrame thread starter macrumors member

    Joined:
    May 2, 2008
    Location:
    Dallas, TX
    #4
    I gave this a try. I'm not very familiar with Console, but I'll tell you what I observed. We'll see whether or not I was looking in the right place.

    I wasn't exactly sure where to look in the log files, so I set the Console preferences to bounce the Console icon when an open log is updated. When observing system.log, nothing would occur (no bounce, no update) doing any of the normal eject methods I tried before. Under Console Messages and All Messages, nothing would show up either. It would show that I ran an AppleScript when I tried using the three scripts that I'd created. One showed up as:

    Apr 22 18:58:48 mark-obriens-mac-pro /System/Library/CoreServices/AppleScript Runner.app/Contents/MacOS/AppleScript Runner[402]: CPSGetFrontProcess(): This call is deprecated and should not be called anymore.

    Don't know what that means, if anything at all. Just seems related directly to the AppleScript itself.

    If there's a specific place I should be looking, you may need to point me in the right direction because I'm unfamiliar with Console.
     
  5. rylin macrumors 6502

    Joined:
    Aug 18, 2006
    #5
    It would definitely have shown up in All Messages if OS X was aware there was a problem.

    Does the normal failsafe work? (Hold down left mouse button when rebooting the MP)
    Does pressing eject in Disk Utility (/Applications/Utilities/Disk Utility.app) work?

    If the last one doesn't work, try booting off a Mac OS X Installation disc and running Disk Utility from that.

    My thinking is there's an API for controlling the drive, but calls to it are being intercepted and ignored (or it's simply broken), but drutil speaks "natively" with the drive.

    The normal failsafe definitely speaks natively, but I'm unsure if disk utility does.
    It probably does, but it's a good diagnostic check.

    If it doesn't work in disk utility on your Mac, but works in Disk Utility from the installation disk, it's a pretty decent indicator that a reinstall will fix the problem.
     

Share This Page