Eject option disappeared

Discussion in 'Mac Apps and Mac App Store' started by Santino, Oct 13, 2010.

  1. Santino macrumors newbie

    Joined:
    Oct 13, 2010
    Location:
    Florence, Italy
    #1
    Hello everyone,

    so the other day I downloaded a dmg file and installed a piece of software. Forgot what exactly, and when I was done I right-clicked on the mounted dmg but "eject" wasn't there...

    I thought this can't harm much anyway. So I just left it there (even though I couldn't delete the .dmg file in the downloads folder as a result of my decision)

    Later, when I turned the computer on again, the Mac didn't mount it and I could delete the dmg no problem



    The cause? Recently I've been playing around with Onyx, sort of like ignoring the warnings and yellow excalamation marks littered all around, so it's probably that



    So: Anyone know how to restore "eject" in the r-click menu?

    Any tips will be greatly appreciated

    PS: I haven't tried inserting a CD in the superdrive yet, not sure it's very wise considering the nature of the issue at hand
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    There is also the option to select the mounted volume (.dmg or CD/DVD) on the Desktop or in a Finder window and pressing Command + E to eject the mounted volume. Or you can drag the icon for the mounted volume from the Desktop onto the Trash icon in the Dock, which changes into a EJECT symbol. Or you can use a Finder window and click on the little eject icon right next to the name of the mounted volume, which is listed in the Sidebar under devices.

    But I don't know how to get back the EJECT option in the context menu, though I hardly use it.
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    You were clicking on the actual volume and not on the .dmg file, right? I know, but sometimes you have to ask the stupid questions just to be sure.

    Beyond that, I can't fathom how you could have removed something like that from the contextual menu, even with Onyx (it doesn't really get into changes like that, and for that matter I don't know of anything that does). Try it with a regular disk, as noted, you will still have plenty of other methods of ejecting the disk.

    jW
     
  4. Santino, Oct 13, 2010
    Last edited: Jun 8, 2011

    Santino thread starter macrumors newbie

    Joined:
    Oct 13, 2010
    Location:
    Florence, Italy
    #4
    I didn't expect a response this fast, you guys truly make a great forum, bravo!



    For the sake of testing I clicked on Google Earth's dmg:

    @spinnerlys: Sadly none of your solutions worked, I tried everyone of them

    @Mal: Yes, I've been clicking on the little volume icon that shows up on the desktop (no worries about stupid questions)
    Following your suggestion, I inserted a CD; same exact result
    To eject the CD -and the dmg file- I used Disk Utility, as advised in other threads regarding CDs stuck inside the computer

    So, while the CD has been ejected the problem hasn't been solved; the simple eject command, whichever way it is given (through the eject button on the keyboard, the finder, contextual menu etc) is still nowhere to be found.

    Ideas? Anyone?
     

Share This Page