Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

flifish

macrumors member
Original poster
Dec 6, 2012
50
0
Wyoming, USA
My slow internet is not a wifi issue as I plugged directly into my ethernet. It is so slow that speed tests time out on me. Does anyone else have this problem and or have a solution? A pc near by is racing through the net but i'm stuck in the slow lane on the iMac late2012. I have plenty of memory...
 

beebarb

macrumors 6502
Sep 10, 2015
288
258
I have an iMac of a similar model to yours, if not the same, and I have no real issues beyond those caused by my router itself.

But, one thing different about my configuration, is I have disabled AirDrop because the way it works has the potential to cause Wi-Fi and Bluetooth interference, as it constantly forces a hidden ad-hoc Wi-Fi/Bluetooth hybrid network, which some network configurations don't like one bit.

Try disabling AirDrop to see if that helps.
As I recall, you disable it by typing the following into Terminal:
defaults write com.apple.NetworkBrowser DisableAirDrop -bool YES
 
  • Like
Reactions: carlosj

flifish

macrumors member
Original poster
Dec 6, 2012
50
0
Wyoming, USA
I have an iMac of a similar model to yours, if not the same, and I have no real issues beyond those caused by my router itself.

But, one thing different about my configuration, is I have disabled AirDrop because the way it works has the potential to cause Wi-Fi and Bluetooth interference, as it constantly forces a hidden ad-hoc Wi-Fi/Bluetooth hybrid network, which some network configurations don't like one bit.

Try disabling AirDrop to see if that helps.
As I recall, you disable it by typing the following into Terminal:
defaults write com.apple.NetworkBrowser DisableAirDrop -bool YES
Thank you for the suggestion. I turned off all airdrops in the house. At first I thought it had worked, but after 3 speed tests none were nearly as fast the one PC in the house. I hate to say the windows machine (a cheap one at that) is beating the "nice" iMac.
 

leventozler

macrumors 6502
Feb 18, 2009
323
151
Thank you for the suggestion. I turned off all airdrops in the house. At first I thought it had worked, but after 3 speed tests none were nearly as fast the one PC in the house. I hate to say the windows machine (a cheap one at that) is beating the "nice" iMac.

try

sudo su -
sysctl -w net.inet.tcp.doautorcvbuf=0
sysctl -w net.inet.tcp.doautosndbuf=0
sysctl -w net.inet.tcp.recvspace=1048576
sysctl -w net.inet.tcp.sendspace=131072


Changes are not permanent, just restart your mac if it doesn't work.
 

beebarb

macrumors 6502
Sep 10, 2015
288
258
Thank you for the suggestion. I turned off all airdrops in the house. At first I thought it had worked, but after 3 speed tests none were nearly as fast the one PC in the house. I hate to say the windows machine (a cheap one at that) is beating the "nice" iMac.
You may need to restart or logout to see the full effect.

Unfortunately, if this doesn't help, I don't know what else could be causing your problems, as I have limited experience dealing with Wi-Fi problems.
 

flifish

macrumors member
Original poster
Dec 6, 2012
50
0
Wyoming, USA
You may need to restart or logout to see the full effect.

Unfortunately, if this doesn't help, I don't know what else could be causing your problems, as I have limited experience dealing with Wi-Fi problems.
This is NOT a wifi problem. As wifi has been eliminated as a problem. I turned it off and used a cable to connect. Still slow internet. Thanks for trying!
 

beebarb

macrumors 6502
Sep 10, 2015
288
258
This is NOT a wifi problem. As wifi has been eliminated as a problem. I turned it off and used a cable to connect. Still slow internet. Thanks for trying!
Sorry, little slip-up there, I meant to write 'networking problems'. :oops:
Still had 'Wi-Fi' on the brain from recalling how AirDrop works.
 
  • Like
Reactions: flifish

flifish

macrumors member
Original poster
Dec 6, 2012
50
0
Wyoming, USA
Have you tried restarting your router?
Yes, and I even tried a different router. Both routers give the same performance with the iMac but a PC zipped around the internet like a nascar around the track. I troubleshooted for 1-½ hours with my service provider.
 

DeltaMac

macrumors G5
Jul 30, 2003
13,528
4,429
Delaware
Have you tried swapping out the ethernet cable on your Mac?

What OS X version did you use before El Cap?
Has your Mac generally been slow, or has it only started with El Cap?
 

flifish

macrumors member
Original poster
Dec 6, 2012
50
0
Wyoming, USA
Have you tried swapping out the ethernet cable on your Mac?

What OS X version did you use before El Cap?
Has your Mac generally been slow, or has it only started with El Cap?
Good ideas... The main ethernet may be difficult as I have an odd system and it comes down from the roof.
I have mostly been out of town since Sept 1. I didn't notice the lackluster speed in August.
 

dsemf

macrumors 6502
Jul 26, 2014
435
108
Good ideas... The main ethernet may be difficult as I have an odd system and it comes down from the roof.
I have mostly been out of town since Sept 1. I didn't notice the lackluster speed in August.

In the "can't hurt to try" mode:

System Preferences >> Network, select Ethernet connection, select Advanced, select TCP/IP. Set Configure IPv6 to Link-Local only.

DS
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.