OS X El Capital and realMyst

Discussion in 'Mac and PC Games' started by steamwolf, Nov 16, 2015.

  1. steamwolf macrumors newbie

    steamwolf

    Joined:
    Nov 16, 2015
    Location:
    Norfolk, England
    #1
    I upgraded (?) my iMac from Yosemite to El Capital last week, no problems, or so I thought, everything seems to be running OK. Not sure about the much vaunted 'speed increases' but never mind.
    On Wednesday, I discovered that Myst, the game from 20 odd years ago, in the form of realMyst, was for sale in the Apple App Store, and duely downloaded, but it won't run. It won't even launch!
    I contacted Cyan, re the game, and was told that there are compatibility issues with nVidia GPUs, and El Capitan. They suggested trying to run in 'windowed' mode, but as the game will not even launch, I can't get into windowed mode anyway! Cyan have said that it needs yet another update from Apple for El Capitan!
    Contacted Apple Support, who denied any nVidia/El Capitan issues, said it was probably my iMac at fault, so I ran diagnostics, which came back with no faults at all.
    Tried deleting and downloading again, exactly the same issues, won't launch.
    In contact with Apple support, set up a 'new user' just as a test, still same issues.
    If I try to launch the game, the Myst book icon transfers from Launchpad to dock for about 5 seconds, then vanishes; small window opens entitled verifying "realMyst app" with a 'loading bar', which fills from left to right. Once full, little windows vanishes again, and thats is, nothing at all happens, zilch, damn all!
    Computer spec is iMac, 27" late 2013 build. 3.4GHz intel core i5, 24 GB 1600 MHz DDR3, NVIDIA GeForce GTX 775M 2048 MB.
    Apple suggested rolling back to Yosemite, but that seems a stupid thing, and in any case I can't get Time Machine to do the work back!

    Anyone got any ideas?
    At least, for now, I've got a refund from the app store, but I'd like to be able to run the game, in my dotage!
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #2
    Working fine for me in El Capitan. I'm using the Steam version though, and I use nVidia's Web Drivers.

    From what you're describing, though, it sounds like an App store verification issue and not something with the graphics. Tried logging out of iCloud and back in again? There was a big app store verification kerfuffle a few days ago where certifications expired, and some users had to log out of iCloud to get their MAS apps working again. Do you have other MAS apps that are working?
     

Share This Page