El Capitan and Java

Discussion in 'OS X El Capitan (10.11)' started by richayden, Jun 9, 2015.

  1. richayden macrumors newbie

    Joined:
    Jun 9, 2015
    #1
    Hey, spent the day with El Capitan and have it running pretty well, one project was to rid my 2009 iMac of Java. I did all the usual things that are posted all over the web but am left with this pop up alert at startup and at other seemingly random moments it also appears. There are certain things I could not get rid of, i.e., System/Library/Java - don't know if this is what is causing this or not. Any ideas are welcome and appreciated. More info just leads to Java download...

    Screen Shot 2015-06-09 at 8.08.20 PM.png
     
  2. NetoBullet macrumors newbie

    NetoBullet

    Joined:
    Apr 3, 2013
    #2
    After many attemps, this solved the JAVA issue here:
    1. Install Netbeans Java from here:
    http://www.oracle.com/technetwork/java/javase/downloads/index-jsp-138363.html
    (make sure to download netbeans version!)
    2. After installing, go to /Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents
    3. Open Info.plist and edit it as follow:
    Change:
    <key>JVMCapabilities</key>
    <array>
    <string>CommandLine</string>
    </array>
    To:
    <key>JVMCapabilities</key>
    <array>
    <string>CommandLine</string>
    <string>JNI</string>
    <string>BundledApp</string>
    </array>

    That's it
     
  3. richayden thread starter macrumors newbie

    Joined:
    Jun 9, 2015
    #3
    Were you getting the same notification? Or is this just to get java working with El Capitan?
     
  4. mgp2015 macrumors newbie

    mgp2015

    Joined:
    Jun 20, 2015
    #4
    Do I have to uninstall JAVA before installing Netbeans?
     
  5. ibrad33 macrumors newbie

    Joined:
    Oct 2, 2015
    #5
    I have this issue too!
     
  6. dugbug macrumors 65816

    dugbug

    Joined:
    Aug 23, 2008
    Location:
    Somewhere in Florida
    #6
    You can just disable rootless and use the apple Java install package. I avoid Java in system area but if you need to do it like in Mavericks there is a way.
     
  7. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #7
    It sounds like you have something running at startup that needs java - that prompt is telling you where to go to download it. Have a look at your startup items first and if there's nothing obvious there it could be a service that needs Java
     
  8. sportsnapper macrumors member

    sportsnapper

    Joined:
    Mar 21, 2011
    Location:
    UK
    #8
    I tried to install the latest version of Java from Oracle so I could install Eclipse. Just wouldn't work, no error message, nothing. Disabling SIP (rootless) let the instal run properly, an I now have a Java pane in system config. Terminal is still stubbornly saying that I only have 1.6 - though the system pane is saying 1.8 as I would expect. Path issue I think?
     

Share This Page