El Capitan changing my System Preferences

Discussion in 'OS X El Capitan (10.11)' started by paieye, May 17, 2016.

  1. paieye, May 17, 2016
    Last edited: May 17, 2016

    paieye macrumors regular

    Joined:
    Nov 14, 2008
    #1
    I use Preview and Skim every single day for hours a day working on documents. I always set System Preferences to General, Recent Items 10. EC infallibly changes my settings back to Recent Items None.

    Some of the technical sites say "The .plist file is corrupted. Go to Library/Preferences and drag the file named com.apple.recentitems.plist into the Trash and empty it. When you open System Preferences again a new com.apple.recentitems.plist file will be created and you should be able to change the number of Recent Items without issue."

    Is there no easier way of dealing with this ? And why is this file becoming corrupted ? Is there nothing that I can do to prevent this from happening ?
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Probably not. Who knows? (very few extremely bright programmers with no social skills might) Since you don't know the cause, no.
     
  3. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #3
    This solution isn't applicable to OS X El Capitan. Try the following instead:

    1. Open Terminal.
    2. Enter the following:

      mv "${HOME}/Library/Application Support/com.apple.sharedfilelist"{,~disabled}
    3. Restart your Mac.
     
  4. paieye thread starter macrumors regular

    Joined:
    Nov 14, 2008
    #4
    Thank you both, but, before you had replied, I chose Recent Items 10. then shut down the computer. I rebooted, and as if by magic all was well. However, if this happens again, I shall certainly try your suggestion, R2.
     

Share This Page