El Capitan Disk Utility - Partition option greyed out

Discussion in 'Mac Basics and Help' started by lexya, Oct 25, 2015.

  1. lexya macrumors newbie

    Oct 25, 2015
    Hi guys,

    I updated to El Capitan and I wanted to partition my external hard drive, which I have completely emptied and erased and formatted to the non-encrypted OS X Extended (Journaled). Unfortunately the option to partition on the top is greyed out. I have rebooted my computer, but still nothing yet. Does anybody have an idea why I can't partition and what I could do to fix it?
    Thank you so much!
  2. DeltaMac macrumors G3


    Jul 30, 2003
    You have to select the hard drive (the line with the model number, not the line with the name that you gave the partition.)
    Then, the partition option will be active.
  3. lexya thread starter macrumors newbie

    Oct 25, 2015
    THANK YOU SO MUCH!!! I can't believe I missed that. Have a great Sunday
  4. dbanderson1 macrumors member

    Oct 15, 2013
    I am having issues as well. I have an external HD that I was using to back up to two computers. I had it partitioned to do this. I no longer wish to have the second partition but when I click the line with the HD name, the partition button is still greyed out? How do re-partition it. Screen Shot 2015-11-02 at 8.55.47 PM.png
  5. DeltaMac macrumors G3


    Jul 30, 2003
    Normally, your screen shot should show that Partition choice is available when you choose the Toshiba line.
    But, likely that won't work when your Toshiba has a Master Boot Record partition map.
    You will probably need to remove all partitions - Erase will do that from the Toshiba line, as your screen shot shows.
    Then, you should be able to get to the Partition tab, and change the partition map to GUID.
    Before doing that, you will want to copy anything you want to save to another drive, as you would lose everything that is not backed up somewhere else.
  6. krulisuk, Nov 18, 2015
    Last edited: Nov 18, 2015

    krulisuk macrumors newbie

    Nov 18, 2015
    I had a similar issue on a newly purchased 128GB USB drive. I found a solution here where after entering the below command I got my disk partitioned by the terminal without any issues (just make sure you type in the correct disk number instead of disk4):

    diskutil partitionDisk disk4 1 GPT HFS+ newdisk R

    Once partitioned I had an option to add partitions to the disk. Disk Utility then prompted for journaling to be enabled on the new partition before additional partitions could be created. After activated the new partition press File then Enable Journaling.

    After these steps I was able to add or modify partitions on the USB drive. Hope it helps
  7. flysKINNardLee macrumors newbie


    Dec 22, 2015

    Yes that helped Tremendously!!!!! I have been fighting with this for 3 days now so THANK YOU SO MUCH krulisuk
  8. sarahd macrumors newbie

    Mar 18, 2016
    I can believe you missed it! I can't believe this is the only place I've found it. But so happy I did.
  9. meesteridle macrumors newbie

    Oct 17, 2013
    My partition button was greyed out, too. I didn't think about the command line option. Thank you so very much!
  10. Lukinson macrumors newbie


    Apr 29, 2016
    Hi - I am experiencing exactly the same problem, BUT even when I know to click on the section of the hard drive on the drop down section - THE 'ERASE' Icon IS STILL GREYED OUT, help?
  11. b0fh666 macrumors 6502a


    Oct 12, 2012
    god knows what apple was thinking when they decided to cripple DU beyond any recognition.

    had to learn how to use diskutil when upgraded to el crapitan, and never had to even consider using it before that.

    wonder if yosmite's disk utility runs/works well on el capitan... anyone tried?
  12. DeltaMac, Apr 29, 2016
    Last edited: Apr 29, 2016

    DeltaMac macrumors G3


    Jul 30, 2003
    Is your external hard drive formatted NTFS? You can't erase an NTFS formatted drive, without adding third party drivers to your system - although choosing the device instead of the individual partition SHOULD work.
    If it is a more normal Mac format (MacOS Extended, etc), then you should be able to select the Partition tab, and remove the partition.
    Removing the partitions will also erase the drive.
  13. eleniboulou macrumors newbie

    Jul 20, 2016

    I have a similar issue but different. I can open the partition tab, but all the options that would actually allow me to make a partition are all faded out and wont let me click. Why??? Screen Shot 2016-07-20 at 4.52.23 PM.png
  14. ThemacNub macrumors regular

    Aug 26, 2010
    Hey Eleni,

    I had the exact same problem. I found erasing the disk and formatting it to OSX extended journaled allowed you to then partition the drive into whichever format you like. It's a bit awkward that it works this way, but should get the job done.
  15. supermariofan25 macrumors regular


    Feb 7, 2011
    The entire drive MUST be formatted as Mac OS Extended Journaled with GPT partition table before you can add partitions. This seems to be a limitation of Disk Utility.
  16. jula macrumors newbie


    Aug 14, 2016
    Hi Guys

    I have the same problem and after using the command prompt the partition option is no longer grey out. However, my problem is not solved. I still cannot partition my external drive because now the Enable Journaling option is greyed out - anyone encoutner this problem before?
  17. DeltaMac macrumors G3


    Jul 30, 2003
    Journaling enabled is the normal default, so there normally is no reason to enable it.
    And, if the icon to enable is greyed out, then you can assume that journalling is already enabled. The "enable" choice should be greyed out if journalling is already enabled, which is probably what you have.

    In Disk Utility, click on a partition (and not the drive itself), then press Command-I, you will see an information window. One of the lines in that window will be "journaled", and should say "Yes", and that's it...
  18. saluki13 macrumors newbie


    Oct 2, 2016
    North Reading,MA
    I just had this same problem. I selected the disk in disk utility and then chose "Erase". This then proceeded to enable journaling on my new WD external drive. Then I could partition.
  19. tjwilliams25 macrumors 6502

    Aug 10, 2014
    That is because the FAT32 file system only supports drives up to 2TB and you can only have files up to 4GB on it. If you select the Ex-FAT file system option you should be able to format your drive. However, this is only necessary if you plan on using this disk with non-Mac systems as the HFS+ file system works better with Macs and is what I would recommend.
  20. BondPPQ macrumors newbie

    Sep 20, 2016
    I have this same "greyed out" problem on all my buttons to partition a disk and I see these instructions above and from the link - http://apple.stackexchange.com/ques...at-on-a-usb-key-in-os-x-mountain-lion-disk-ut

    but this is instructions on formatting it to another Windows format not an Apple format so my question is in this terminal command

    diskutil partitionDisk disk4 1 GPT HFS+ newdisk R ...do I need to change it to

    diskutil partitionDisk disk1 1 GPT GPT MyDiskName R ...to ("cut" not split equally) my current GPT partition into 2 GPT partitions and if so where do I specify the desired disk sizes because I would not like to have them equal sizes?
  21. Greengecko19 macrumors newbie

    Jan 26, 2018
    I stumbled onto the answer to this crazy problem -- you just have to click on the View control in the upper left and View All Devices!! That shows all the parent/child devices and you can see if there are multiple partitions on an individual drive. I had the same problem with a new Seagate 5 TB drive that was formatted for NTFS. It kept telling there wasn't "enough space" and all sorts of messages when I kept trying to erase and partition. As soon as I clicked All Devices, I was able to select the parent, and then everything worked as it should.
  22. Goebz macrumors newbie

    Jul 31, 2012

    I finally got this to work, then my drive wasn't large enough UG!
  23. metter macrumors newbie

    Jan 28, 2018
    I have the grey out issue and I used the command above. It said
    SSD does not appear to be a whole disk. I have a samsung T5 I am trying to clone from my internal hard drive. any guidance is appreciated.
  24. Fishrrman macrumors P6


    Feb 20, 2009
    metter wrote:
    "It said SSD does not appear to be a whole disk. I have a samsung T5 I am trying to clone from my internal hard drive. any guidance is appreciated."

    I'm thinking that the t5 comes with some kind of factory-installed proprietary software that prevents the entire drive from being erased (by apps such as Disk Utility).
    It could even have some kind of proprietary partition format.

    These setups can usually be overcome, but I believe you have to use some kind of special app (in this case, from Samsung) to remove the software and partition.
    I don't have a t5, so I don't know for sure.
    You would probably have to go to Samsung's site to download it.

    The following URL downloads something called "Samsung Portable t5 Activation Software" for Mac:
    This may -- or MAY NOT -- be what you need.
  25. metter macrumors newbie

    Jan 28, 2018
    Thank you for the prompt response. I use the activation software above. It does not recognise the ssd. I rang Samsung and they have escalate the issue internally and hope to hear from them. I then update the to high Sierra and then reinstall the software. I followed the prompt and it does not appear to do much. I then proceed with CCC and copy any way. I am experimenting to see if i reinstall the OSS on the SSD and see if that will allow me to boot from the SSD. Will let you know.

Share This Page

41 October 25, 2015