El Capitan download stuck on waiting

Discussion in 'OS X El Capitan (10.11)' started by neutrak, Sep 30, 2015.

  1. neutrak macrumors newbie

    Joined:
    Oct 16, 2014
    #1
    So my download got paused and resumed a few times and now it's stuck on waiting. I tried clicking "check for unfinished downloads" but that didn't work. I tried deleting the El Capitan file and removing it from the launchpad. Didn't work. What can I do?

    Also am I safe to update from El Capitan Dev Beta 1 or do I need to wipe?
     
  2. !!! macrumors 6502

    !!!

    Joined:
    Aug 5, 2013
    #2
    You should defiantly erase your computer, especially since you are having this issue.
     
  3. neutrak thread starter macrumors newbie

    Joined:
    Oct 16, 2014
    #3
    I'm not really sure why this App Store error would make it more necessary for me to do a wipe. But it's fine, I can update my yosemite partition instead. Either way, I need to get this download going.
     
  4. bryan85 macrumors regular

    Joined:
    Jun 18, 2010
    #4
    yeah, my download has been creeping along at 2Mbps for the past couple of hours(350Mbps connection). I cancelled it, killed the download, rebooted, and now I'm stuck at waiting. Im thinking the servers are just being hammered right now.
     
  5. neutrak thread starter macrumors newbie

    Joined:
    Oct 16, 2014
    #5
    Ok so I solved this by deleting the files and restarting my computer. Back to 13 Hour wait time. FML.
     
  6. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #6
    Same exact situation here
     
  7. RMeira macrumors newbie

    RMeira

    Joined:
    Oct 1, 2015
    #7

    What files did you delete ?? i'm at the same situation ..
    tnks
     
  8. neutrak thread starter macrumors newbie

    Joined:
    Oct 16, 2014
    #8
    Delete the partly downloaded El Capitan file from your applications folder then remove the icon from launchpad and reboot then start download again.
     
  9. RMeira macrumors newbie

    RMeira

    Joined:
    Oct 1, 2015
  10. dtsteinb macrumors newbie

    Joined:
    Aug 4, 2014
    #10

    Worked for me as well.... thanks for the info guys.
     
  11. cvandenhaute macrumors newbie

    cvandenhaute

    Joined:
    Oct 1, 2015
    #11
    It did not work for me, no matter what I try, I keep getting stuck at 1,21Gb, restarted it several time, always ended there
     
  12. Broadus, Oct 1, 2015
    Last edited: Oct 1, 2015

    Broadus macrumors 6502a

    Joined:
    Oct 26, 2011
    #12
    Thanks for posting this. I had the same problem and a search brought me to your thread and this post. I followed your instructions and it worked. The download is going well, about halfway done. It looks like it will take about 35 minutes overall.

    Edit: Until it got to a little over 5GB, all was going along well. Then it started crawling. Looks like it going to take as long to download the final GB as the first 5. At least it's downloading now, whereas it was stuck on waiting before.
     
  13. bobbytomorow macrumors 6502

    bobbytomorow

    Joined:
    Nov 10, 2007
    Location:
    Left Coast
    #13
    Christ what a fiasco this has been trying to download, first off I started off with a 1-2 day wait time now its stuck on pause after over 12 hours of trickle downloading...now I have to start from scratch again. Hopefully I can find a copy on usenet because I'm not down with waiting 2 friggin days
     
  14. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #14
    Not only it stuck while downloading, but even when I find the dmg elsewhere(so, no need to download from apple servers), stuck again!
    Unbelievable and tragic!
    :(
     
  15. maitoman macrumors newbie

    maitoman

    Joined:
    Oct 3, 2015
    #15

    I've found the solution:

    1. Close the "App Store" App
    2. Open "Terminal"
    3. Enter defaults write com.apple.appstore ShowDebugMenu -bool true
    4. Open the "App Store" app
    5. Now you have in the menu-item "Debug" - open it - and open "Show Download Folder"
    6. Delete all files and folders in the folder "com.apple.appstore"
    7. Close the "App Store" app
    8. Restart the Mac
    9. Open the "App Store" app an repeat the download.
    Now the download should work!

    If you want to hide the debug-menu again just enter in Terminal:
    defaults write com.apple.appstore ShowDebugMenu -bool false
     
  16. mjlv macrumors newbie

    mjlv

    Joined:
    Oct 3, 2015
    #16
    Thank you. Worked for me as well. :)
     
  17. barney1 macrumors newbie

    Joined:
    Oct 4, 2015
    #17

    Thanks for this. Worked like a charm - installed within an hour.
     
  18. fred_el_capitan macrumors newbie

    Joined:
    Oct 5, 2015
    #18
    i had the similar problem : i stopped the download and after it's stuck on waiting.
    i removed the little file El Capitan in Applications... but, still the same problem.
    i simply log in with another account on my Mac,
    start the download again (but with the same Apple Id account)
    it worked...
     
  19. Amontalvo89 macrumors newbie

    Amontalvo89

    Joined:
    Nov 4, 2015
    #19
    Worked for me, thank you very much
     
  20. Shamus46, Nov 4, 2015
    Last edited: Nov 4, 2015

    Shamus46 macrumors newbie

    Shamus46

    Joined:
    Nov 18, 2014
    Location:
    Cirencester, UK
    #20
    Have the same problem on my mid-2011 iMac 21.5". I've deleted the partly downloaded El Capitan from the Applications folder, but how to I get rid of the icon in Launchpad?
    - - - - -
    That problem resolved itself but, on restarting the download, El Capitan still hangs up. This always happens at the same point; the progress bar stops at 1.88GB and says: "calculating . . . ". Any tips for this?
     
  21. Shamus46 macrumors newbie

    Shamus46

    Joined:
    Nov 18, 2014
    Location:
    Cirencester, UK
    #21
    This looks promising, maitoman, but I need further guidance as I've never used Terminal before. When I open it, i get a window, headed "shane - bash - 80x24" (I'm Shane, btw), in which I find this: "Last login: Thu Nov 5 17:44:30 on ttys000
    android-16225f934c4c3563:~ shane$". Where do I 'enter defaults', per your guide? Thank you in advance your patience and help on this.
     
  22. sweet_mnemonic macrumors newbie

    Joined:
    Jan 16, 2016
    #22
    --- Post Merged, Jan 16, 2016 ---
    So I don't have any files to remove. still stuck on waiting. this is really frustrating.
     
  23. CrashX macrumors regular

    Joined:
    Apr 13, 2012
    #23
    Ugh... Thanks for the tips on this everyone.

    I'm trying to help a friend with an early 2011 MBP. Non-bloated Snow Leopard isn't allowed, so I'm hoping El Capitan will save her Mac from being thoroughly Cook'd. At least the download is showing only an hour and a half. I really hope it speeds things up for her - Yosemite is just like this mountain of bloatcrap seemingly taxing the life out of her machine. It's really sad. Ah well... hopefully this download won't stall out.
     
  24. Rachavol macrumors newbie

    Rachavol

    Joined:
    Apr 27, 2016
    #24
    Thank you. It works for me!
     
  25. Zzznorch macrumors newbie

    Joined:
    Dec 21, 2011
    #25
    Worked for me too. I held off on El Capitan but with Sierra coming out this fall I realized I needed to update. Unfortunately my Mac kept failing to download due to spotty WiFi at the office. Eventually it just refused to download. This procedure of using the Debug menu worked. The update is downloading now and much faster at home than it did at the office.
     

Share This Page