El Capitan hangs at boot up

Discussion in 'OS X El Capitan (10.11)' started by Seahster, Oct 2, 2015.

  1. Seahster macrumors newbie

    Joined:
    Oct 2, 2015
    #1
    Hi everyone,

    With all you geniuses here maybe someone will have the solution to this. I installed El Capitan yesterday on both my 2012 RMBP and 5k imac. Both seem to install fine and boot up normally. But when I do a restart, both computers get stuck at the black screen with Apple logo. The progress bar remains empty and doesn't move for hours. I tried rebooting with cmd-R but nothing helps apart from reinstalling El Capitan. Then the same thing happens. I can sleep the computer and it wakes up fine. On the first install, it mentioned something about Little Snitch not being compatible but that has already been updated. Restart and it gets stuck in the same place. Please help!
     
  2. darrengrayshon macrumors newbie

    darrengrayshon

    Joined:
    Oct 2, 2015
  3. Seahster thread starter macrumors newbie

    Joined:
    Oct 2, 2015
    #3
    Its extremely frustrating! I just created a bootable OS installer on a USB drive and I'm wiping my MBP and doing a clean install as a test.

    I was panicking when both my computers were showing the dreaded black screen with the apple logo and nothing happening last night as I have projects that need to be done!

    Will report back if it functions properly after the clean install.
     
  4. darrengrayshon macrumors newbie

    darrengrayshon

    Joined:
    Oct 2, 2015
    #4
    I did i fully re-install and have the same issues.....

    I've no idea whats going on but it's extremely annoying
     
  5. amitkapila macrumors newbie

    Joined:
    Jun 30, 2008
    #5

    Do you have MS Office Installed on your Mac ? I am reading about this and it seems to be the culprit.
    I had to restore from my TM Backup and am not going to upgrade to EC just yet. It is scary and I also had many projects that needed doing..
     
  6. darrengrayshon macrumors newbie

    darrengrayshon

    Joined:
    Oct 2, 2015
    #6

    Yes, i do as it happens......

    I've no idea what a TM Backup or EC thing is sadly...

    I've a business to run so cannot be without PC's

    Hope you get it sorted
     
  7. Seahster thread starter macrumors newbie

    Joined:
    Oct 2, 2015
    #7
    Yes I do have MS Office installed. Should I kill it?

    By the way, my clean install on my MBP just finished and it works normally. Restarted and it loaded as it should, so its some legacy app on my original Mac that is causing the bloody headache. Its going to be a real pain reinstalling stuff though.

    I might try to uninstall MS Office on my iMac and reboot to see if that solves the problem, but part of me is scared to do it because if I get stuck on that screen again, its a pain to get reinstall the OS just to get to the desktop.
     
  8. iorangutan macrumors member

    iorangutan

    Joined:
    Nov 2, 2009
    #8
    I had the exact same problem, but with a bit of searching and fixing I got it working:

    I did two things in Terminal in Recovery Mode (Command +R when starting up):
    • Moved some unsupported third party kext's
    • Unencrypted the drive (removed FileVault)

    First following instructions on the many similar threads over on the developer forum, like this one: https://forums.developer.apple.com/thread/21173

    I ran in recovery mode in Terminal these commands, which simply moved these following two files into a Unsupported Directory (note "Machintosh HD" needs to be the name of your main Volume which may be different):

    If you have FileVault enabled you will need to unlock your disk, which you can to using Disk Utility and unlocking the volume from the menu, (or by using this terminal commands suggested in the link below)

    then

    cd "/Volumes/Macintosh HD/Library/Extensions/"
    mkdir Unsupported
    mv CIJU* Unsupported
    mv BJ* Unsupported​

    Two files moved from this directory (which were the only two matching files on my Mac form the above Developer Forum thread). These are related to my Canon Printer and its drivers, so no big deal.
    • BJUSBLoad.kext
    • CIJUSBLoad.kext

    If you search through these Developer forums you'll see Max108 has given specific instructions to many other users, and gets them to move some other unsupported / third party files they may have on their Macs. The above two were the only ones I need to move.

    Then removed FileVault Encryption following the instructions I found here:
    https://derflounder.wordpress.com/2...ecrypt-your-filevault-2-encrypted-boot-drive/

    Booted all good! El Capitan running.

    May wait a while before re-enabling FileVault - and if this crashed it again I will update here...
     
  9. Seahster thread starter macrumors newbie

    Joined:
    Oct 2, 2015
    #9
    I've managed to get mine working also, but you beat me to the post.

    I was also referencing Max's (at the Apple Developer forums) instructions to remove 3rd party kexts which might be causing the problem.

    I've removed ...

    CalDigitHDProDrv.kext
    LittleSnitch.kext

    and now my iMac boots up properly.

    But on my rMBP, which I have already wiped and clean installed El Capitan, I have Little Snitch installed and running with no problems. I don't know what the issue is, unless the conflict is specific to the different Macs (one is an iMac, the other a rMBP).
     
  10. Joszwa macrumors newbie

    Joined:
    Oct 5, 2015
    Location:
    Holland
    #10
     
  11. Seahster thread starter macrumors newbie

    Joined:
    Oct 2, 2015
    #11
    After all the removal of 3rd part kexts etc from the Extensions library and working ok for a past day or two, it has come back again. My clean installed rMBP is running fine so I think ultimately, I'm going to have to bite the bullet and do a wipe and clean install on my iMac.

    Real pain the bum.
     
  12. Joszwa macrumors newbie

    Joined:
    Oct 5, 2015
    Location:
    Holland
    #12


    It's so weird.... This problem is already reported weeks ago.
    Many people are facing problems like you reported. And no real solution yet....
    BTW... I don't have FileVault enabled... System hangs in boot.
     
  13. Seahster thread starter macrumors newbie

    Joined:
    Oct 2, 2015
    #13
    I did the whole shifting 3rd party kexts thing and it worked for a bit, but left my system a bit funky, with it getting stuck in boot every now and again. Finally bit the bullet and clean installed on both my computers now and it has been working fine.

    I fear that might be the only real solution for now.
     
  14. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #14
    10.11.1 installer, has the same problem.
    Stuck in apple logo screen forever.
    It is supposed, they fixed this problem.
    They didn't.
     
  15. mperkins37 macrumors 6502a

    mperkins37

    Joined:
    Jan 17, 2007
    Location:
    Phoenix, AZ
    #15
    My MAcPro is hanging at 50%,if I try & boot recovery it gets to 70% or so, Safe mode, gets to 80% none of them lets me get anywhere1 HELP!. Need this booting ASAP! HELP!
     
  16. amitkapila, Nov 28, 2015
    Last edited: Nov 28, 2015

    amitkapila macrumors newbie

    Joined:
    Jun 30, 2008
    #16
    @mperkins37,

    Hi,

    Here is how I resolved it.
    Some background: I first installed el capitan on my MacBook Air. 11 inch. 2013. Had the exact same problem.
    Solution : Found that it was a conflict with Office 2011. Did a restore from Time Machine backup back to Yosemite. Uninstalled Office 2011 (not a simple move to trash uninstall - the proper uninstall) There are many instructions on this here is the one I liked and used. http://www.howtogeek.com/212650/how-to-completely-uninstall-office-2011-for-mac/

    For me this resolved the issue.

    I also have a MacMini and I kept that on Yosemite until I resolved my MacBook Air. Then did the exact same thing i.e uninstalling Office 2011 - and it worked.

    Also there are some useful tips from October on this thread.

    Hope that helps.
     
  17. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #17
    Does the new update works well, or still hangs at boot?
     
  18. amitkapila, Dec 9, 2015
    Last edited: Dec 9, 2015

    amitkapila macrumors newbie

    Joined:
    Jun 30, 2008
    #18
    The 10.11.1 worked fine.

    I just downloaded 10.11.2 and all is well.

    I can't get Outlook (Office 2016) to work with my office mail. This has been an issue ever since I upgraded to El Capitan. It worked fine with Outlook (Office 2011) on Yosemite. Waiting for MS to resolve this. If they will !!
     

Share This Page