El Capitan, SMTP & Fetchmail

Discussion in 'Mac OS X Server, Xserve, and Networking' started by hwojtek, Nov 1, 2015.

  1. hwojtek macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #1
    I've ran out of ideas.
    It was very simple on 10.5: fetchmail downloads mail for local OS X Server users, the mail gets delivered to mailboxes, job done.

    Now I've switched to El Capitan and ran into problems. Since there is no fetchmail binary included in El Capitan, I downloaded the source and built it myself. It works OK, but fails to deliver to local mailboxes. The emails are downloaded from the ISP mailboxes, but they get lost somewhere between fetchmail and postfix. Here is a sample log:

    Code:
    Nov  1 18:01:20 miniserver fetchmail[5174]: SMTP> RCPT TO:<wojtek@localhost>
    Nov  1 18:01:20 miniserver postfix/smtpd[5176]: NOQUEUE: reject: RCPT from localhost[::1]: 550 5.1.1 <wojtek@localhost>: Recipient address rejected: User unknown in local recipient table; from=<SRS0=X44E=K3=mail-withlove.com=sare0006962390-wojtek=mydomain.com@mymailprovider.com> to=<wojtek@localhost> proto=ESMTP helo=<miniserver.home>
    Nov  1 18:01:21 miniserver postfix/smtpd[5198]: 6A69010AC57: client=localhost[127.0.0.1]
    Nov  1 18:01:21 miniserver postfix/cleanup[5184]: 6A69010AC57: message-id=<20151101170120.8353110AC46@miniserver.home>
    Nov  1 18:01:21 miniserver postfix/qmgr[383]: 6A69010AC57: from=<>, size=5136, nrcpt=1 (queue active)
    Nov  1 18:01:21 miniserver postfix/smtp[5189]: 8353110AC46: to=<SRS0=X44E=K3=mail-withlove.com=sare0006962390-wojtek=mydomain.com@mymailprovider.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.91, delays=0/0/0/0.91, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6A69010AC57)
    Nov  1 18:01:21 miniserver postfix/qmgr[383]: 8353110AC46: removed
    Nov  1 18:01:21 miniserver fetchmail[5174]: SMTP< 550 5.1.1 <wojtek@localhost>: Recipient address rejected: User unknown in local recipient table
    Nov  1 18:01:21 miniserver fetchmail[5174]: can't even send to wojtek!
    Nov  1 18:01:21 miniserver fetchmail[5174]: SMTP> RSET
    Users, domains and e-mail addresses are set up in Server app. I can send from "anyuser@localhost" to "wojtek@localhost" and it will be delivered to my mailbox - so the log stating user unknown in local recipient table is not right. I honestly have no idea what I did wrong.
     
  2. eemnee macrumors newbie

    eemnee

    Joined:
    Jan 4, 2016
    Location:
    Around Vienna, Austria
    #2
  3. hwojtek thread starter macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #3
    Oh, thanks for this!
    I did solve this problem a couple of weeks ago (just a second ago I had honestly ZERO idea how), but indeed it involved this setting exactly. I know now it was not a stupid coincidence and can finally put this into my "documentation", in case all my backups failed and I had to start over again...
     
  4. eemnee macrumors newbie

    eemnee

    Joined:
    Jan 4, 2016
    Location:
    Around Vienna, Austria
    #4
    You are welcome, Wojtek. Good you found it yourself. It made me crazy for some hours. For everybody else, this seems to be the exact way:
    Check, if you have the "is blabla here" address in your mail server. Check exactly, how the notation is. Take that notation for your fetchmail.rc. Fully qualified, if needed.
     

Share This Page