El Capitan: Time Machine quits after I enter it

Discussion in 'OS X El Capitan (10.11)' started by mgru, Oct 19, 2015.

  1. mgru macrumors newbie

    Joined:
    Oct 19, 2015
    #1
    I tried entering Time Machine for the first time today since upgrading to El Capitan. It starts to show the TM screen and then quits. I cannot enter Time Machine.

    I find that one person reported this issue in the Apple Discussions a few days ago but he has not received a reply.

    My iMac is regularly doing TM backups - it's just I can't go back into them. This is, to say the least, not a happy situation.

    Any assistance would be most welcome.
     
  2. uajafd macrumors newbie

    uajafd

    Joined:
    Jun 17, 2015
    #2
    Fire up /Applications/Utilities/Console.app, then try to start Time Machine again, watch it crash, see messages logged into the console.
     
  3. mgru, Oct 19, 2015
    Last edited: Oct 19, 2015

    mgru thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #3
    Thanks for replying so promptly uajafd.

    This the start of the crash report (don't know if it will give you any clues) :

    Process: Finder [330]
    Path: /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
    Identifier: com.apple.finder
    Version: 10.11 (10.11)
    Build Info: Finder_FE-960000002000000~11
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: Finder [330]
    User ID: 502

    Date/Time: 2015-10-19 17:38:45.724 +0300
    OS Version: Mac OS X 10.11 (15A284)
    Report Version: 11
    Anonymous UUID: 686D*******


    Time Awake Since Boot: 820 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY

    Application Specific Information:
    *** Terminating app due to uncaught exception 'NSRangeException', reason: '*** -[__NSArrayM objectAtIndex:]: index 0 beyond bounds for empty array'
    terminating with uncaught exception of type NSException
    abort() called
     
  4. uajafd macrumors newbie

    uajafd

    Joined:
    Jun 17, 2015
    #4
    Wow, so it's Finder that actually crashes. And you've found a bug. :)

    But what if you delete /Library/Preferences/com.apple.TimeMachine.plist (or move it somewhere safe) just to see if you can start TM from scratch?
     
  5. mgru thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #5
    Deleted the plist. Time Machine asked me to set up the TM disk anew but sadly it's still crashing as before.
     
  6. mgru thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #6
    OK. Solved it from another search.

    It's an El Cap bug involving secondary monitors. When I unplug the second monitor TM works fine!

    See details here: http://packetslave.com/blog/2015/10/15/unable-to-enter-time-machine-on-os-x-10.11-el-capitan/

    There is a suggestion on that site to uncheck “Displays have separate Spaces” in Mission Control prefs to solve the issue but it didn't work for me. Unplugging the external monitor solved it.

    Thanks again for your help uajafd.
     
  7. uajafd macrumors newbie

    uajafd

    Joined:
    Jun 17, 2015
    #7
    o_O

    /me takes a note

    And those people keep telling me GNOME on Linux is buggy, heh
     

Share This Page