El Capitan Update Freezes at Restart

Discussion in 'OS X El Capitan (10.11)' started by theatrrap, Oct 29, 2015.

  1. theatrrap macrumors newbie

    Joined:
    Dec 15, 2007
    #1
    So I hope I haven't don't things that cause this to be a permanent problem, but here is what has happened so far:

    I updated to El Capitan about a week ago or so. Everything was going ok, though I didn't notice any great upgrades and it seemed to be a bit slower...but whatever.

    Yesterday my Mail app kept crashing when I tried to open it. I thought maybe the new OSX had a problem so I checked for an update and poof, there was one. I decided to try that before doing anything else. I downloaded it and it restarted the computer as updates do. It then got to what I would guess is about 60% or so, and stopped. I did that at 6:00pm last night and left it until 8:00am this morning. No change.

    So I then started researching. I did a hard shut off and startup. It took me to the login screen and I put in my password and it went to the loading screen, got to 60% and stopped...or an hour.

    I then tried going to the recovery and repairing the drive but no problems there.

    So I tried booting in safe mode. I don't think it actually did, I would press shift but it wouldn't actually seem to be any different then normal startup. Regardless, this didn't seem to help.

    I tried resetting the NVRAM I think it is...Option + Command + P + R. This definitely did something, after it restarted this time I get to the login screen and put in my password and it stop with 0% loaded...

    So now what? I can reinstall the OSX and I can go to a previous backup...but I am an idiot a haven't run Time Machine in like 6 months so I would lose a lot of important work documents. Is there any hope? What can I do?
     
  2. fnegrin, Oct 29, 2015
    Last edited: Oct 29, 2015

    fnegrin macrumors newbie

    Joined:
    Oct 11, 2014
    #3
    Yes, many of us have had the same issue. Here is the very strange solution. But it works! And it is easy to do.


    resetting the SMC should enable you to boot once more (but the problem will come back next time you shut down) . this is how https://support.apple.com/en-us/HT201295

    Once you have booted:

    1) Open Terminal

    2) Enter "system_profiler SPExtensionsDataType > ~/Desktop/kextList.txt" without the quotes and hit return(this will take a while to run).

    3) There should now be a kextList.txt file on your desktop, open it and press both the "Apple(Command)" and "F" keys to bring up the find.

    4) In the find field insert "Obtained from: Not Signed" Copy the destination to the .kext file to a list for use later. (Click next to cycle through all of them.) Example: /System/Library/Extensions/JMicronATA.kext

    5) Browse your drive to /System/Library/Extensions and remove any of the unsigned kext files.


    6) Reboot and you should be all set. one last SMC reset might be needed.


    The problem is that el capitan 's installer does not properly clean up your extensions folder of pesky .kext files left over from applications you no longer have and some are incompatible with el capitan's boot up process. You have to do it yourself.



    Good luck. This should solve your problem!

    if the sms reset doe snot help you boot, get another mac for a few hours: start up yours in target mode (press T as you start up) with the two computers connected to each other via firewire or thunderbolt and make a clone of your hard disk onto an external hard disk with carbon copy cloner . then restart your mac via internet recovery (command option R) and reinstall your original system, then download el capitan again and reinstall it. then use the clone you mad of your hard disc to ,migrate all your settings and data and apps using Migration assistant. Then you still have to do the stuff described above

    it takes a while but you will have lost nothing.

    best
     
  3. fnegrin, Oct 29, 2015
    Last edited: Oct 29, 2015

    fnegrin macrumors newbie

    Joined:
    Oct 11, 2014

Share This Page