El Capitan will not log in automatically to my admin account on startup

Discussion in 'OS X El Capitan (10.11)' started by madeirabhoy, Jul 30, 2015.

  1. madeirabhoy macrumors 6502a

    Joined:
    Oct 26, 2012
    #1
    it used to before, but i cant say if the problem is from upgrading to el capitan, or to a short lived attempt to have a 2nd log in account so i could use back to my mac with a separate icloud address.


    basically my mac used to start up automatically logging into my account which is an admin account but with my name.

    now it insists on starting up with a login screen to choose either my account or the proper 'admin' account.

    when i go into users & groups it says 'automatic login' and beside it is my named account.

    yet when i restart it asks me to login.

    its a real pain, not just the extra few seconds but i often find my computer crashes when using teamviewer, which i use to login from work into my mac, but i have teamviewer as 'open on startup' and a fixed password, so its not a big issue, if it crashes i wait for it to restart and then login. now i cant.
     
  2. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #2
    File Vault does not allow automatically login. So you might have activated it during the upgrade process.
     
  3. madeirabhoy thread starter macrumors 6502a

    Joined:
    Oct 26, 2012
    #3
    thanks, good answer, but its not that. looked in settings and 'file vault is turned off for the disk macintosh hd'
     
  4. madeirabhoy thread starter macrumors 6502a

    Joined:
    Oct 26, 2012
    #4
    figured it out, and its a really stupid reason.

    when i installed el capitan, it had asked if i wanted to use my icloud password as my admin password, and i thought why not, and it must have been then that it stopped logging in automatically.

    now i quite liked only having one password, so i turned off the 'use icloud password' tickbox, then when it asked me for a new password, i put in the same password as my icloud password. result, back to automatically logging in :)
     
  5. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #5
    It's been that way since Yosemite. I do the exact same thing (use the same password but not set up as "use iCloud password".
     
  6. gxgrant macrumors newbie

    Joined:
    Mar 14, 2014
    Location:
    Arizon
    #6
     
  7. gxgrant macrumors newbie

    Joined:
    Mar 14, 2014
    Location:
    Arizon
    #7
    Sorry for my ignorance on this, I'm fairly new to the Macs but having the same issue on login. Where would I shut off the part on entering an iCloud password? Thanks!
     
  8. Mac Fly (film) macrumors 65816

    Mac Fly (film)

    Joined:
    Feb 12, 2006
    Location:
    Ireland
    #8
    That sucks for my situation. I too like my iCloud password for everything, but dislike having to enter it upon startup.

    I want both.

    I just sent feedback, you should too: http://www.apple.com/feedback/macosx.html
     

Share This Page