El capitan with problems in FILE dialog (unsolved)

Discussion in 'OS X El Capitan (10.11)' started by srsilva, Feb 10, 2016.

  1. srsilva macrumors newbie

    Joined:
    Feb 10, 2016
    #1
    Hey guys, I had an annoying problem with el capitan in my macbook pro 15" 2010, i5, ssd, fresh install; it has all the updates and a couple days ago I was having this problem: whatever the app you were using, you couldn`t open the FILE dialog that it become frozen... simple like that; even a browser, if you try to save a page it froze; when it happened it also coudln`t use text editor, facetime, imessage... it keept blinking in the screen but never started up. I tried with lots of apps and the same thing happened. In that case the only thing that worked for me was to restart OSX, which is not acceptable for me, because we can`t do that very often, this is not acceptable for a unix OS.

    Well, if think that if is there some possibility of only restarting this part of the OS, of the framework, it would be nice, as we do with network service or other modular OS like linux.

    If someone have some idea I would be grateful!

    Thanks,

    Srs
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
  3. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #3
    Hi, thanks for your answear. Well, I cant say for sure that it's not, but both modules are new; is there a way that I check it like memtest in linux/pc??
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    https://support.apple.com/en-gb/HT201257
     
  5. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #5
    I have checked the RAM modules, but there is no error; I thought that maybe that problem could be cause by filesystem errors, when, at the time that the system needed to retrieve information from that dialog (save, file...), somehow it could not read or access it from the filesystem; what do you think of this theory? my ssd is new and I have checked permissions and done what I can to check it`s integrity, but I`m using el capitan, that seems to be a disk utility program with more limitations than the previous versions... how can I double check this FS? thanks
     
  6. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
  7. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #7
    shouldn`t I be in the single user mode or something like that? for a complete and check?
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Sure, You could run fsck in single user mode,
    or you could boot to your recovery system, and run Disk Utility on your boot drive from there.
     
  9. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #9
    Just run it as is. If it can't fix it, it will ask you to boot into recovery mode.
     
  10. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #10
    Hey guys, this is a great place, you answear so quickly, and I`m happy for this; thanks!!

    I first run the disk utility and frst aid (thanks for letting me know that this is the same fsck, I came from linux world and to know that means a lot for me) from the normal system; it gave me error code 8 and fixed; but I booted in recovery mode and ran again, and again it found some problems and fixed it; I hope it could be all for now, it does not deteriorate the filesystem so quickly; but I think that now I must wait and see, isn`t??

    By the way, whats the difference between press D and Command+R during boot? only the graphical tools? the D option would be only for command line tools? thanks
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    Starting up pressing D starts the Apple Hardware Test. Command-R starts the recovery partition.

    When you get the continuing error, are you running Repair Disk from the Recovery Partition? If not, try that.

    Usually error code 8 is followed by the message that the disk wasn't repaired and you need to reboot into the recovery partition and repair it from there.
     
  12. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #12
    I was linux user before come to OSX and rarely had problems with corrupting filesystem; my systems used to have months of uptime; do you know if osx filesystem corrupts itself very often? is there is not media problem, can I expect some days or weeks of uptime, just closing the lid? just remembering that my trimforce command is set. Thanks.
     
  13. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #13
    It should run indefinitely without corruption unless you have a system crash or a force-quit.
     
  14. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #14
    Ok, I`m sad to give this news, but after 3 days from the last time that I`ve booted in recovery and used fsck to try to fix any problem with the file system, I have the same symptoms again:
    - can`t open tons of apps (mail, contacts, notes, imessage and facetime)
    - others opens but I can`t see the main window (maps, text editor, reminders)

    In mail I just see the colorful cursor spinning a lot, and nothing really opens.

    I need some more advice, because I don`t know what to do... can this be a problem within my SSD? is there a way to check the filesystem in a more lower level where I can verify the possibility of the equivalent of bad blocks in the SSD (dead memory I think)??

    If nothing happens I will need to reboot again; I think that if the system could not read the SSD, then a reboot will never fix this, but strangelly everything backs to normal...

    ????
     
  15. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #15
    Does Repair Disk show more errors? If so, we need to figure out what is causing the corruption. How old is the SSD? Also, what was the result of the hardware test?
     
  16. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #16
    Hi John,
    No, the Repair Disk do not show any errors, as you can see in this image:
    [​IMG]
    (sorry for the portuguese layout)

    Hardware Test did not showed any errors either:
    [​IMG]

    After reboot the OS works like a charm, but this is not normal; about the ssd, it was new when I bought it and if the Disk Utility does not find any errors in the filesystem, can I assume that the SSD is fine?
    Thanks
     
  17. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #17
    Please download the free Etrecheck http://etrecheck.com , run a report and post the result back here.
     
  18. IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #18
    I would at this point schedule and have hardware checked by Apple, esp. if inside first weeks or months.

    The SSD should map out bad cell page. Memory could be issue. And after 28 years with Macs and others, would hope by now 10.11.3 is better (just got Apple refurb'd MacBook 2015 came with El Capitan).
     
  19. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #19
    Hey guys, thanks for the reply; my macbook is not new, so check hardware by apple I think that should be my last option for now!! here is the report:

    EtreCheck version: 2.9.4 (254)
    Report generated 2016-02-19 14:52:43
    Download EtreCheck from http://etrecheck.com
    Runtime 2:00
    Performance: Excellent


    Click the [Support] links for help with non-Apple products.
    Click the [Details] links for more information about that line.
    Click the [Check files] link for help with unknown files.

    Problem: Apps are crashing

    Hardware Information:
    MacBook Pro (15-inch, Mid 2010)
    [Technical Specifications] - [User Guide] - [Warranty & Service]
    MacBook Pro - model: MacBookPro6,2
    1 2,53 GHz Intel Core i5 CPU: 2-core
    8 GB RAM Upgradeable - [Instructions]
    BANK 0/DIMM0
    4 GB DDR3 1067 MHz ok
    BANK 1/DIMM0
    4 GB DDR3 1067 MHz ok
    Bluetooth: Old - Handoff/Airdrop2 not supported
    Wireless: en1: 802.11 a/b/g/n
    Battery: Health = Normal - Cycle count = 10

    Video Information:
    Intel HD Graphics
    NVIDIA GeForce GT 330M - VRAM: 256 MB
    Color LCD 1440 x 900

    System Software:
    OS X El Capitan 10.11.3 (15D21) - Time since boot: about 3 hours

    Disk Information:
    MTFDDAK256MAM-1K1 disk0 : (256,06 GB) (Solid State - TRIM: Yes)
    EFI (disk0s1) <not mounted> : 210 MB
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB
    steff (disk1) / : 254.83 GB (131.60 GB free)
    Core Storage: disk0s2 255.20 GB Online

    MATSHITADVD-R UJ-898 ()

    USB Information:
    Apple Computer, Inc. IR Receiver
    Apple Inc. Built-in iSight
    Apple Card Reader
    Apple Inc. Apple Internal Keyboard / Trackpad
    Apple Inc. BRCM2070 Hub
    Apple Inc. Bluetooth USB Host Controller

    Configuration files:
    System Integrity Protection status: disabled

    Gatekeeper:
    Anywhere

    Unknown Files:
    /Library/LaunchDaemons/com.spotflux.Spotflux.tun.plist
    /Library/LaunchDaemons/org.freelan.freelan.plist
    ~/Library/LaunchAgents/openvpn.net.privatetunnel.app.plist
    3 unknown files found. [Check files]

    Kernel Extensions:
    /Applications/spotflux.app
    [not loaded] com.spotflux.Spotflux.tap (1.0 - 2015-11-09) [Support]
    [loaded] com.spotflux.Spotflux.tun (1.0 - 2015-11-09) [Support]

    System Launch Agents:
    [loaded] 159 Apple tasks
    [running] 77 Apple tasks

    System Launch Daemons:
    [loaded] 201 Apple tasks
    [running] 87 Apple tasks

    Launch Agents:
    [loaded] com.adobe.AAM.Updater-1.0.plist (2016-02-14) [Support]
    [loaded] com.google.keystone.agent.plist (2015-12-17) [Support]
    [loaded] com.oracle.java.Java-Updater.plist (2015-10-02) [Support]
    [loaded] com.teamviewer.teamviewer.plist (2015-09-30) [Support]
    [loaded] com.teamviewer.teamviewer_desktop.plist (2015-09-30) [Support]
    [loaded] com.adobe.AAM.Updater-1.0.plist (2015-10-02) [Support]
    [loaded] com.adobe.AdobeCreativeCloud.plist (2015-10-02) [Support]
    [loaded] com.adobe.CS5ServiceManager.plist (2015-10-02) [Support]
    [loaded] org.gpgtools.Libmacgpg.xpc.plist (2015-09-23) [Support]
    [loaded] org.gpgtools.gpgmail.enable-bundles.plist (2015-03-08) [Support]
    [loaded] org.gpgtools.gpgmail.patch-uuid-user.plist (2015-03-08) [Support]
    [loaded] org.gpgtools.gpgmail.updater.plist (2015-08-14) [Support]
    [loaded] org.gpgtools.macgpg2.fix.plist (2015-03-08) [Support]
    [running] org.gpgtools.macgpg2.shutdown-gpg-agent.plist (2015-03-08) [Support]
    [loaded] org.gpgtools.macgpg2.updater.plist (2015-03-08) [Support]

    Launch Daemons:
    [loaded] com.cyberghostsrl.CyberghostPrivilegedHelper.plist (2015-10-28) [Support]
    [loaded] com.github.IngmarStein.Monolingual.Helper.plist (2015-10-27) [Support]
    [loaded] com.google.keystone.daemon.plist (2015-12-17) [Support]
    [loaded] com.oracle.java.Helper-Tool.plist (2015-10-02) [Support]
    [running] com.prey.agent.plist (2015-11-16) [Support]
    [loaded] com.spotflux.Spotflux.tun.plist (2015-11-09) [Support]
    [loaded] com.teamviewer.Helper.plist (2015-09-30) [Support]
    [loaded] com.teamviewer.teamviewer_service.plist (2015-09-30) [Support]
    [loaded] com.tunnelbear.mac.tbeard.plist (2015-12-08) [Support]
    [loaded] com.adobe.agsservice.plist (2015-10-02) [Support]
    [loaded] com.microsoft.office.licensing.helper.plist (2010-09-08) [Support]
    [failed] org.freelan.freelan.plist (2013-11-09) [Support] [Details]
    [loaded] org.gpgtools.gpgmail.patch-uuid.plist (2015-03-08) [Support]
    [loaded] org.wireshark.ChmodBPF.plist (2015-11-22) [Support]
    [loaded] org.wireshark.XQuartzFixer.plist (2015-10-02) [Support]

    User Launch Agents:
    [loaded] com.adobe.AAM.Updater-1.0.plist (2016-02-14) [Support]
    [loaded] com.victorpimentel.TVShowsHelper.plist (2016-01-23) [Support]
    [loaded] openvpn.net.privatetunnel.app.plist (2016-02-18) [Support]

    User Login Items:
    Dropbox Aplicativo (/Applications/Dropbox.app) (2016-02-17)
    Android File Transfer Agent Aplicativo (~/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app
    MailButler Aplicativo (~/Applications/MailButler.app)

    Other Apps:
    [running] com.apple.xpc.launchd.oneshot.0x10000001.iTerm (2015-10-27)
    [running] com.apple.xpc.launchd.oneshot.0x10000002.Sublime Text 2 (2015-06-20)
    [running] com.apple.xpc.launchd.oneshot.0x10000009.EtreCheck (2016-02-14)
    [running] com.feingeist.MailButler.766112 (2016-02-11)
    [running] com.getdropbox.dropbox.385632 (2016-02-17)
    [running] com.google.GoogleTalkPluginD.722912.BA434F18-8C61-45AD-8A93-51D53C2BEF2A (2015-12-17)
    [running] com.google.android.mtpagent.774112 (2012-10-15)
    [running] com.hp.devicemonitor (2015-10-27)
    [running] net.privatetunnel.ovpnagent
    [running] org.mozilla.firefox.781152 (2016-02-19)

    Internet Plug-ins:
    AdobeAAMDetect: 3.0.0.0 - SDK 10.9 (2015-10-02) [Support]
    QuickTime Plugin: 7.7.3 (2016-01-22)
    Default Browser: 601 - SDK 10.11 (2016-01-22)
    o1dbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-17) [Support]
    SharePointBrowserPlugin: 14.6.1 - SDK 10.6 (2016-02-18) [Support]
    Google Earth Web Plug-in: 7.1 (2015-10-27) [Support]
    googletalkbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-11) [Support]
    Silverlight: 5.1.40416.0 - SDK 10.6 (2015-10-27) [Support]
    JavaAppletPlugin: Java 8 Update 73 build 02 (2016-02-10) Check version

    Safari Extensions:
    Adblock Plus (2016-02-19)
    Enpass Password Manager (2016-01-23)

    3rd Party Preference Panes:
    Cameras (2015-10-27) [Support]
    FUSE for OS X (OSXFUSE) (2015-10-25) [Support]
    GPGPreferences (2016-02-17) [Support]
    Growl (2015-10-27) [Support]
    Java (2016-02-10) [Support]
    MacFUSE (2008-12-19) [Support]
    MouseZoom (2015-10-27) [Support]
    NTFS-3G (2010-10-11) [Support]
    TeXDistPrefPane (2015-10-02) [Support]
    TVShows (2015-10-27) [Support]
    Web Sharing (2013-01-26) [Support]

    Time Machine:
    Auto backup: YES
    Volumes being backed up:
    steff: Disk size: 254.83 GB Disk used: 123.23 GB
    Destinations:
    TM_backups [Local]
    Total size: 300.44 GB
    Total number of backups: 5
    Oldest backup: 07/11/15 23:55
    Last backup: 05/02/16 18:28
    Size of backup disk: Too small
    Backup size 300.44 GB < (Disk used 123.23 GB X 3)

    Top Processes by CPU:
    6% WindowServer
    4% mdworker(16)
    3% kernel_task
    2% com.apple.AddressBook.InternetAccountsBridge
    1% firefox

    Top Processes by Memory:
    2.30 GB com.apple.WebKit.WebContent(20)
    1.04 GB firefox
    721 MB kernel_task
    639 MB Preview
    311 MB mdworker(16)

    Virtual Memory Information:
    42 MB Free RAM
    7.96 GB Used RAM (1.06 GB Cached)
    0 B Swap Used

    Diagnostics Information:
    Feb 19, 2016, 11:39:46 AM Self test - passed
    Feb 19, 2016, 10:09:41 AM /Library/Logs/DiagnosticReports/Messages_2016-02-19-100941_[redacted].hang
    /Applications/Messages.app/Contents/MacOS/Messages
    Feb 19, 2016, 10:02:34 AM /Library/Logs/DiagnosticReports/Contacts_2016-02-19-100234_[redacted].hang
    /Applications/Contacts.app/Contents/MacOS/Contacts
     
  20. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #20
    You have a number of things that I am not familiar with, like SpotFlux and GPG. Are you sure that software is up to date and El Capitan compatible? You might check on the developer's web site.

    Also, as an experiment, try booting in safe mode (by holding down the shift key). That will stop things like GPG and Spotflux from loading. You can then see if you have the same problem with them not loaded.

    Finally, it looks like your last Time Machine backup was Feb. 5. Why is that? Have you shut Time Machine off? If not, Your problem could conceivably be caused by Time Machine unsuccessfully trying to back up.
     
  21. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #21
    Hey John, thanks for the comments; I have not shut time machine backups off, it`s just that I use a external hard drive to store the backups and it`s not everyt day that I plug it on and do the backup; but I will do this backup more often, who knows it can help; as for the other apps (spotflux and GPG) I always try to check if they are compatible with my El Capitan, but some may not be; but would an app like this cause such kind of problems? it`s so strange, because when I cannot load that apps, or a part of the system like FILE dialog, it seems that the system cant read those files or access that part of the memory... Anyway, thanks for the hints, I will try to do the backup and reboot in safe mode. And let`s see when it will be the next crisis.
     
  22. NoBoMac, Feb 19, 2016
    Last edited: Feb 19, 2016

    NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #22
    Noticed that SIP has been disabled: installed any sort of Finder replacement or customer skin software or something of similar customization? Can see that possibly damaging something.

    Also noticed Monolingual in the report: have you trimmed out other languages? Seen threads in the past where removing a language can have adverse affects (recall something along the lines of not to remove Chinese, since for some reason, that's a base language on OS X).

    Bit of a pain, and depending on what you use the machine for, might not be possible to be "down" for a while, but, might want to do another clean install, no copying of anything from back-ups. Can copy over documents, but leave behind all off Apple /Library information and any user account ~/Library files. You now have a true clean install. Manually setup wi-fi settings, mail, etc. Then, start to re-introduce 3rd party apps, VPN, etc. one-by-one. Run for a while to see if the problem re-appears. Hopefully will re-install something that will cause the machine to go bad. You now know what program is causing the grief. Hopefully.
     
  23. srsilva thread starter macrumors newbie

    Joined:
    Feb 10, 2016
    #23
    hey guys, I`m coming here because I just find out something new (never solved the problem and could not reinstall the system yet): if I logout my acount and log in again I can use the system, or if I use another account! So whatever the problem is, happens only in my account after some hours/day of use... what possible could do such a thing??? I`m trying not to reinstall because I do not have time for that, as you noticed.
    Thanks!
     

Share This Page