Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Droobiemus

macrumors member
Original poster
Feb 7, 2014
45
47
On Public Beta 2 on my Retina Macbook Pro, Safari YouTube videos ask for the latest Flash or Quicktime versions. Has anyone else experienced this?

Thanks in advance.
 

Ritsuka

Cancelled
Sep 3, 2006
1,464
968
YouTube works without flash like before. Maybe you had an old flash version installed.
 

You are the One

macrumors 6502a
Dec 25, 2014
633
795
In the present
I have removed Flash, Youtube works fine.

I have gotten the black screen with "Update to latest Flash/QT player" on some websites with embedded Youtube videos. It's irregular and happens just on a few sites.

I don't care what content I may miss, I will never install Flash again. Hopefully it will die and disappear from the net soon.
 

Droobiemus

macrumors member
Original poster
Feb 7, 2014
45
47
Hmm, I did have ClickToFlash extension installed. It seems removing that solved the problem.
 

Gary500

macrumors regular
Nov 25, 2009
171
6
Does anyone have a problem with the 2.0x speed or the 1.5x speed? The sound is distorted compared to Yosemite or even Google Chrome.
 

StarShot

macrumors 65816
Mar 31, 2014
1,151
397
it will be in System Preferences (under the apple menu), there as a preference pane...

Thanks. I GOT it. Judging by the posts above, I apparently don't need it to run youtube videos. A bigger question is do I need it for my OS X operation?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.