El Captain Hibernation Question

Discussion in 'OS X El Capitan (10.11)' started by wepiii, Aug 16, 2015.

  1. wepiii macrumors 6502

    Joined:
    Sep 22, 2012
    #1
    Can anyone tell me how to set my 2010 macbook pro to hibernate instead of sleep on El Captain? I have tried all the terminal commands i could think of, but they ones for previous versions of OS X don't seem to work. I have a 2 SSD raid 0 setup if that matters. I don't mind waiting longer for my mac to start up, because as it is now the battery is always dead anyway when i come back to it. Any help is greatly appreciated.

    Thanks!
     
  2. WCWcam macrumors newbie

    Joined:
    Oct 5, 2015
    Location:
    Alberta
    #2
    You may have some incompatible apps being booted up when you boot up.
    Try the following:
    Boot up in safe mode to try and confirm if some apps are causing a problem.
    If this solves the problem - delete all items from start up items you have set up in your system preferences under accounts. Then add them back one app at a time to find out which is the culprit.
     
  3. wepiii thread starter macrumors 6502

    Joined:
    Sep 22, 2012
    #3

    Thanks for the reply but i'm a little confused by your response... I'm not having any trouble starting up, I just can't figure out how to set my mac to turn off the battery and hibernate as opposed to simply "sleeping" and draining my battery completely before the next time I can use it.

    Thanks!
     
  4. WCWcam macrumors newbie

    Joined:
    Oct 5, 2015
    Location:
    Alberta
    #4
    Because El Captain allows your laptop to back itself up and download mail and perform other functions tied to iCloud, it appears that we may now have to log off from iCloud before we can put our laptop to sleep the old fashion way. There has to be a check box in system preferences to shut off iCloud otherwise our laptops have to be plugged in when put to sleep.
     
  5. WCWcam macrumors newbie

    Joined:
    Oct 5, 2015
    Location:
    Alberta
    #5
    I discovered:Under System preferences go to Energy Saver and click on "Enable Power Nap" This should/may stop your battery from draining.
     
  6. wepiii thread starter macrumors 6502

    Joined:
    Sep 22, 2012
    #6
    I don't have that option... I think it may be for newer MacBooks only unfortunately. I don't understand why apple would make the only option to "sleep". I believe hibernate used to be an option on the MacBooks but maybe i'm remembering that incorrectly. With an SSD, it just doesn't take that long to power it back up, and my battery lasts much longer.
     
  7. EatinPonies macrumors newbie

    Joined:
    Feb 15, 2016
    #7
    Did you ever find a solution to this? I'm the exact same boat: 2010 MBP and "sleep" still eats through the battery, as our hardware doesn't support "power nap".
     
  8. wepiii thread starter macrumors 6502

    Joined:
    Sep 22, 2012
    #8
    Nope. I think i've decided it is apple's way to get you to upgrade to a new macbook. Which is unfortunate, because other than mine always being dead, I could use it for several more years. With 8GB of ram and an SSD it runs as fast as I need it to.
     
  9. EatinPonies macrumors newbie

    Joined:
    Feb 15, 2016
    #9
    Gotcha. Same here.

    And you've already tried
    pmset -a hibernatemode 25??
     
  10. wepiii thread starter macrumors 6502

    Joined:
    Sep 22, 2012
    #10
    Yeah. Before El Capitan that worked fine, but it doesn't seem to work anymore
     
  11. EatinPonies macrumors newbie

    Joined:
    Feb 15, 2016
    #11
    Bummer. I just made that edit and I was gonna try it out. Aside from waiting overnight to see if it works, is there any obser
    Interesting... I just did that to mine and it's definitely doing something different than just sleeping... FWIW, here's what I get now from a pmset -g:

    $ pmset -g
    Active Profiles:
    Battery Power-1*
    AC Power-1
    Currently in use:
    halfdim 1
    sms 1
    hibernatefile /var/vm/sleepimage
    gpuswitch 2
    disksleep 10
    sleep 10 (sleep prevented by AddressBookSourceSync)
    hibernatemode 25
    ttyskeepawake 1
    displaysleep 2
    acwake 0
    lidwake 1
     
  12. ztagman macrumors newbie

    Joined:
    Apr 16, 2016
    #12

    type sudo pmset -a hibernate mode 25 and it will work perfectly.
     

Share This Page