eMac and Epson printer problems

Discussion in 'Mac Accessories' started by iaddict, Mar 20, 2011.

  1. iaddict macrumors 6502

    Joined:
    May 15, 2007
    #1
    My dad has an eMac running OS 10.4.11. I have downloaded latest Epson drivers for the Epson Stylus CX5000. Even after installing the driver, I am unable to print. I've tried looking up on Apple's and Epson's website yet I haven't found anything to really help with this situation.
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    You didn't give us much info!
    Did you Add the printer in Print & Fax/Printer Setup?
    Did you delete and re-Add after installing new driver?
    Did the printer show up there?
    Did it automatically show the correct model in Print Using?
     
  3. iaddict thread starter macrumors 6502

    Joined:
    May 15, 2007
    #3
    Yes, I have done the Add printer several times. Deleted it and added it at least 5 or 6 times. The problem is that the printer has never worked with this computer. He had an identical eMac that the printer worked fine with but since getting this one, I have not been able to get the printer to work with it at all. The driver doesn't show up when I go to add a printer so I'm not sure why that is the case. It does show the correct model if I choose to print but that's only because I have typed the name in.
     

Share This Page