eMac kernel panic

Discussion in 'PowerPC Macs' started by DamoRed, Nov 3, 2009.

  1. DamoRed macrumors member

    Sep 9, 2006
    Hi all,

    What a night it's turning out to be! :(

    Yesterday, I did a 7 pass erase of my eMac HD before doing an intended archive and reinstall of OS X 10.4. The problem started when I put the disc in, I started the installation process, which prompted me to restart. When it restarted, it came up with a kernel panic... and the OSX 10.4 disc locked in the CD drive.

    I don't know if this or any other part of the text that comes up will be of any help, but anyway.. this is the last line of it. If any other part of it is of relevance, I'll type that too in a later post.

    Top line reads...

    [panic(cpu 0 caller 0x002DFAA80: Unable to find driver for this platform: PowerMac4.4"

    Last line reads...

    Darwin Kernel version 8.4.1: Tue Jan 3 2006: root: xnu-792.7.90.obj~1/Release_PPC
    Panic: We are hanging here... You don't say! Apple's line of irony, eh?

    So I get to trying figuring out the problem. I tried restarting from the CD, but still the same panic. I started in Target Disc mode connected on this iMac. Went into Disk Utility, click verify, which says it needs to be repaired. Click repair... then... This volume appears to be ok.

    Restart and cross fingers... BAH! kernel panic again!

    I then search and find out about single user mode and FSCK. Restarted in single user mode and still the same. I tried fsck and while I'm told to type /sbin/fsck -fy the keyboard is not even recognised and there is no flashing cursor :mad:

    So at this point, I don't know where to turn next. I also have the 10.3 Panther install discs, which may or may not make any difference, but until I can retrieve the 10.4 disc from the drive, I won't know that.

    Any and all help will be most gratefully appreciated

    Thank you

  2. DamoRed thread starter macrumors member

    Sep 9, 2006
    Desperate measures for desperate times and all that...

    If I went to the considerable bother of disassembling the eMac and got to the CD/DVD drive, would I actually be able to remove the disc from it?

  3. MacHamster68 macrumors 68040


    Sep 17, 2009
    question what emac you have ?
    as the original grey 10.4 tiger disc sets came model specific and it sounds like you tried to install to a 700mhz ,800 mhz 1 ghz , which are powermac 4.4`s with a 2 disc set for a 1.25 ghz or 1.42 ghz model which are powermac 6.4`s
    which would explain the missing driver

    to remove the disc it should be enough to to open the door
    and take a paperclip
    and stick it in the little hole under the tray and the tray should slide out
  4. DamoRed thread starter macrumors member

    Sep 9, 2006
    Thank you, MacHamster, I managed to find the hole for the clip, and put in the Panther disc and went on my merry way.

    Many thanks.


Share This Page