eMac not powering on???

Discussion in 'PowerPC Macs' started by 76ShovelHead, May 29, 2011.

  1. 76ShovelHead macrumors 6502a


    May 30, 2010
    I'ts happened before, but I don't remember it taking this long. I shut the computer off hours ago, and when my mom went to turn it on it does nothing. Pushing the power button does nothing. Afew months ago I went into the case, and accidently forgot the power cord was still attached and ripped it open. I noticed it was missing a prong on the power button but later found out it's supposed to be like that. I have been able to use the power button but sometimes it won't turn on. Could it be the cable? I also thought maybe the PRAM battery? I hit the reset switch on the motherboard and still no response when i tried pushing the power button. Please help :confused: :(
  2. burnout8488 macrumors 6502a

    May 8, 2011
    Endwell, NY
    If you've got the shell off, use a piece of metal (pliers, paperclip, etc) and bridge the two contacts in the socket where the power switch connects to on the logic board. If it turns on, you have a bum power switch. If not, then it's something else.
  3. btbrossard macrumors 6502a

    Oct 25, 2008
    We had an eMac at work that would not turn on when it was shut off unless the power cable was disconnected for a few seconds.

Share This Page